Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How do I activate the gnome-shell user-theme extension in Oneiric with GNOME 3.2? I've installed the package gnome-shell-extensions-user-theme but can't find anywhere on how to activate it. I thought the gnome-shell-extensions-tool was the way but when I run it nothing happens.

share|improve this question
    
did you install gnome-tweak-tool? –  jrg Oct 5 '11 at 16:05
add comment

1 Answer

up vote 2 down vote accepted

Install GNOME Tweak Tool: graphically or use the command line:

sudo apt-get install gnome-tweak-tool

Once installed, open GNOME Tweak Tool (should show up as "Advanced Settings" in the menu) and activate User Theme extension.

Please note that to be able to install or change GNOME Shell themes using GNOME Tweak Tool, after enabling the User Theme extension you may need to restart Tweak Tool or the whole GNOME Shell (press ALT + F2 and enter "r" or log out and log back in). This is not required for other extensions.

share|improve this answer
    
Great! Shouldn't there be a more standard (easier) way of activating these things, though? –  Nordlöw Oct 5 '11 at 19:17
    
shell-extensions aren't "officially" supported -- yet. The GNOME team were too busy trying to get 3 out the door to worry about customisation (and 3.2 largely consisted of bugfixes and repairing some idiosyncracies), but there was enough of the basic functionality there that people were able to write gnome-tweak-tool and start making extensions and themes before the gnome team got around to integrating it properly. It should be a standard part of the system settings from 3.4 onward. –  ovangle Nov 17 '11 at 16:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.