Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having a really hard time getting ddclient (which updates OpenDNS with my current IP address) to work. I have it running as a daemon, but it never succeeds in updating my IP address at openDNS.

To troubleshoot, I am running ddclient from the command line as follows.

(In these examples, values in square brackets [] are stand-ins for the real values for security reasons)

My /etc/ddclient.conf contains:

use=web,, web-skip='IP Address'
login=[my login]
password=[my password]

When I run:

sudo ddclient -daemon=0 -debug -verbose -noquiet

I get:

WARNING:  file /var/cache/ddclient/ddclient.cache, line 3: Invalid Value for keyword 'ip' = ''
WARNING:  skipping update of Home from <nothing> to [my real ip].
WARNING:   last updated <never> but last attempt on Tue Oct  4 08:38:32 2011 failed.

If I rm the cache file, ddclient does work once, but then it fails on subsequent times.

share|improve this question
OP are you still looking for an answer? If so, you may need to repost your question as this is flagged for closure. =) – Ringtail Mar 7 '12 at 19:24
still haven't found a way to make it work – SpashHit Mar 9 '12 at 15:09
Please consider editing your question to provide additional information. This may move your question to the top and revel an answer. – Ringtail Mar 11 '12 at 18:32
What else can I add? – SpashHit Mar 12 '12 at 14:00
have you tried client support? – Ringtail Mar 12 '12 at 19:44
up vote 3 down vote accepted

Known bug - fixed upstream - get the latest version from a PPA

This is/was from a known "bug" -- it's caused by the dynamic DNS provider using the dyndns2 protocol incorrectly and sending malformed responses to ddclient.

The problem has long since been fixed in ddclient (based on one of the patches linked in the trac), but Ubuntu's ddclient is so ancient (inherited from upstream) that it can't even be patched manually. (Ubuntu is on rev. 106/Jan-2009, while the latest is r130/Nov-2011).


  1. Add this PPA with sudo apt-add-repository ppa:nathan-renniewaldock/ppa
  2. sudo apt-get update && sudo apt-get install ddclient (will upgrade if necessary)

The PPA has the latest versions for 10.04, 11.10 and 12.04.

For the curious, here's the patch/buggy bit:

        # bug #10: some dyndns providers does not return the IP so
        # we can't use the returned IP
        my ($status, $returnedip) = split / /, lc $line;
        $ip = $returnedip if (not $ip);
share|improve this answer

You want the newer ddclient package from ppa:nathan-renniewaldock/ppa but beware that this PPA contains many other packages that you might not want if all you want to do is get ddclient working. Use these steps to only upgrade ddclient.

sudo apt-get install python-software-properties
sudo apt-add-repository ppa:nathan-renniewaldock/ppa

Now, as root, create the file /etc/apt/preferences.d/nathan-prefs and edit it to look like this (including the blank line which is important):

Package: *
Pin: release o=LP-PPA-nathan-renniewaldock
Pin-Priority: 400

Package: ddclient
Pin: release o=LP-PPA-nathan-renniewaldock
Pin-Priority: 500

This tells apt-get to ignore packages from the PPA other than ddclient. So now it should be safe to do this to install it:

sudo apt-get update && sudo apt-get install ddclient

Or if you have already installed it, do this:

sudo apt-get upgrade

Just check that only ddclient is going to be upgraded.

share|improve this answer
Its worth noting that this information is no longer valid. If you attempt to follow these instructions in ubuntu 12.04 you get this error: "FATAL: Error loading the Perl module Digest::SHA1 needed for freedns update". To fix this error you need ddclient 3.8.2 but this PPA only has 3.8.1. – frankster Jul 8 '14 at 16:10

skipping update of @ from to 71.422.000.000.

Most of the time when I get this warning after setting up my ddclient
WARNING: file /var/cache/ddclient/ddclient.cache, line 3: Invalid Value for keyword 'ip' = ''
it's because of a typo or just a small tweek in the ddclient.conf file. I need to stop and check it against my domain providers examples line by line.

I use NameCheap because I like the security of their password system which is tied to each domain individually, generated automatically and can be changed quickly and easily.

My latest problem was something that NameCheap does not show in their Knowledgebase example but was something I remembered having to do before. That is that I have to put a comma between the Host Names that I want updated (The name that comes before the Domain Name). So below is my example that currently works with my domain provider.

@, hostname1
missing this tiny little comma throws an error

share|improve this answer
I dont know why this is geting downvotes. If you search for namecheep issues this pops up as a question. Your solution helped me perfectly. Thank you! – nbroeking Jun 10 at 21:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.