Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I switched my sony viao laptop from XP to ubuntu 10.04 recently. I have it connected through router at home. The internet was working fine with XP. With ubuntu, i am not able to connect to interenet.

I am able to update using apt, and i am able to ping too. It seems like there is a DNS issue, when i try to goto sites from firefox, it doesn't work. I tried disabling the ipv6 in firefox config, it doesn't work.

My router is on 192.168.2.1 instead of 192.168.1.1

any ideas on what config i might need to change to make this work? or could this be a drive issue?

share|improve this question
    
I installed firefox and everything works fine on it... –  vijay Oct 14 '10 at 0:23

3 Answers 3

up vote 1 down vote accepted

on a terminal prompt type :

cat /etc/resolv.conf

Output would be like : nameserver 192.168.2.1

copy paste the output here or add to your question, if you have anyother machine you can check whether you can actually get to browse web pages, if you are able to do apt-get update and apt-get upgrade then it is connected to the internet, but DNS isn't working for some reason.

Check with another machine by connecting it to the same router and see if you are able to browse websites, also on the terminal :

you can type :

ping 4.2.2.2 (you will see responses / reply received) you can break the operation by CTRL + C

then type : ping www.google.com (if you receive reply on that too, it means name resolution is working as well).

share|improve this answer
    
the file basically said it was autogenerated by network manager, and it did not have any nameserver information. I modified the file to have nameserver to my router, but it did not work after reboot too. Should i modify the settings in NetworkManager, do you think having it as static IP will work? Just curious, ping to google.com works though, doesn't it need to go through DNS? just trying to understand whats happening... –  vijay Oct 13 '10 at 12:49
    
In your Ubuntu Terminal : Type the following one by one and press enter after each, paste the output cleanly on here : ip route | grep "default via" This should give you your default gateway ifconfig | grep "inet addr" or just type "ip route" without quotes and read the last or second last line which says default and will show your router's address : Have you setup a static ip to your ubuntu box while install or is it taking from dhcp ? –  rihatum Oct 13 '10 at 15:44
    
nameserver 192.168.2.1 Add the name servers to your /etc/resolv.conf file as above. Also, try installing google chrome and test in that, as you mention that ping to google.com works, so may be it is firefox which is playing up. provide the output of the commands above. Also check the link : ubuntuforums.org/… go through it and see if that helps - don't just start making changes - try to see if you can figure it out or ask here with what you cannot understand from it. –  rihatum Oct 13 '10 at 16:08
    
Thanks for replies everyone, I installed chrome on ubuntu and everything works fine ! –  vijay Oct 14 '10 at 0:22

Check your Firefox settings for a proxy (Settings / Advanced / Network / Configure how Firefox connects to the internet).

share|improve this answer

I seem to remember I had a similar issue, and it had something to do with the MTU (maximum transmission unit) of my network interface. You should try setting the MTU of your connection to 1500 or something lower.

You can change the MTU temporarily using ifconfig.

sudo /sbin/ifconfig mtu 1500

If this works and you want to make the change permanent, you should set it in /etc/network/interfaces

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.