Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I am using Natty with with classic GNOME desktop.

I use Empathy and sometimes Skype.

Both these get the online state from the system itself somehow.

If I don't touch my keyboard for a few minutes - even when watching a YouTube clip or something - the inactivity triggers an auto-away state on my messaging apps.

It's synchronized so I imagine its coming coordinated from the system, and not the two apps making the same decision individually.

How can I disable this? I want manual control - I'm only away when I set it to away in a messaging app.

share|improve this question

3 Answers 3

Install dconf-tools and open dconf-editor.

Go to org.gnome.Empathy and change autoaway like you want.

enter image description here

share|improve this answer


Empathy has a default auto-away configured. If you want to change it, hit Alt+F2 and type dconf-editor. On the left hand side you'll a tree view. Click on apps -> empathy. Now you see some settings on the right. The first line is the auto-away setting. If you uncheck it, Empathy will not automatically set you away.


At is a nice answer regarding to Skype: Does my Skype status ever change to 'Away' automatically?

share|improve this answer

Years later, and a similar problem. I use Skype with Lubuntu and the "show me as away after 0 seconds setting" has no effect.

Changing this line in the Skype config.xml so that the value is 0 instead of 1800 worked for me.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.