Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Problem

I've upgraded to 11.10 today, and have been toying with gnome-shell extensions - gnome-shell version 3.2.0.

When it comes to add one to the top panel, I have hit a brick wall. Right-clicking on the panel does nothing.

Am I doing something wrong - is one supposed to add extensions to the top panel by some other method?

Tried

  • "Installing" an extension
  • holding alt while right-clicking on top panel
share|improve this question
add comment

2 Answers 2

you can't add extensions by right clicking the panel. You have to create a dir in ~/.local/share/gnome-shell/extensions/extension_name@your_host

and create there 2 files: extension.js and metadata.json

and add code to whatever you want to add onto panel to extension.js and some info into metadata.json

in gnome-shell 3.0.x in .js you have to add function main() { } in gnome-shell 3.2.x: function enable() { /* code to execute on enabling this extension */ } function disable() { } and function init() { }

share|improve this answer
    
I've done that - what I want to do is add one of the extensions that I've prepared in the manner described to the panel. For example: projecthamster.wordpress.com/2011/07/07/… –  Michael Robinson Oct 4 '11 at 2:50
add comment

To get the "Add to Panel" menu, you need to use Alt super right-click; see also: Panel settings not appearing on right-click in gnome

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.