Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Epiphany browser, and really like it because of it's startup time and small footprint. However, I am unable to make youtube or huhu videos (anything that requires flash) to run on Epiphany. Can you please help me with the configuration. I have Firefox and opera both on my system, and both are able to play Flash based videos on the web.

share|improve this question
    
And what about playing videos at YouTube through HTML5? Does Epiphany support this? Then this can be a partial (only for the sites that have videos in HTML5) and more free solution to the problem. –  imz -- Ivan Zakharyaschev Nov 17 '12 at 20:23
    
There are TONS of videos even on youtube that won't play with HTML5. Supposedly it's because of the ads. –  Karel Bílek Nov 18 '12 at 18:51
add comment

6 Answers

Flash is GTK+2 and Epiphany is GTK+3...that's the problem.

  1. install flash sudo apt-get install flashplugin-installer
  2. install nspluginwrapper sudo apt-get install nspluginwrapper
  3. sudo nspluginwrapper -i /usr/lib/flashplugin-installer/libflashplayer.so
  4. nspluginwrapper -v -a -n -i
share|improve this answer
    
worked for me! 11.10 –  suli8 Feb 6 '12 at 13:31
1  
didn't work in 12.04. $ sudo nspluginwrapper -i /usr/lib/flashplugin-installer/libflashplayer.so --> nspluginwrapper: no appropriate viewer found for /usr/lib/flashplugin-installer/libflashplayer.so –  alfC May 21 '12 at 8:41
    
Not working for me either, but I think it's because there is no 64-bit version of nspluginviewer. I noticed it automatically installed the i386 version with the amd64 version of the wrapper, so I doubt they'll work properly. –  zebasz Jul 5 '12 at 7:24
add comment

I'm on Xubuntu 12.04, the lib is in /usr/lib/flashplugin-installer/.

So in my case the code is:

sudo apt-get install nspluginwrapper
sudo nspluginwrapper -i /usr/lib/flashplugin-installer/libflashplayer.so
nspluginwrapper -v -a -n -i
share|improve this answer
add comment

I'm on Ubuntu 12.04 and in my case I installed flashplugin using Ubuntu Software Centre and so it installed the plugin at /usr/lib/adobe-flashplugin/libflashplayer.so. I did following and Flash worked perfectly in Epiphany 3.4.1.

sudo apt-get install nspluginwrapper
sudo nspluginwrapper -i /usr/lib/adobe-flashplugin/libflashplayer.so
nspluginwrapper -v -a -n -i
share|improve this answer
add comment

I solve problem with adobe flash player in epiphany 3.6 ;-)

This is what I do:

  1. sudo apt-get install adobe-flashplugin nspluginwrapper
  2. sudo nspluginwrapper -i /usr/lib/adobe-flashplugin/libflashplayer.so
  3. nspluginwrapper -v -a -n -i
share|improve this answer
add comment

If you are using Ubuntu 64-bit, install adobe-flashplugin:i386 instead of adobe-flashplugin, before using nspluginwrapper.

sudo apt-get install adobe-flashplugin:i386 nspluginwrapper
nspluginwrapper -v -a -n -i
share|improve this answer
add comment

Go to http://kb2.adobe.com/cps/155/tn_15507.html or http://www.adobe.com/software/flash/about/ in Epiphany.

It should show you if you have flash installed, maybe there is another issue. Flash in Epiphany worked the first time I installed it and loaded youtube.

share|improve this answer
    
It does not work for me on 11.10 Oneiric –  Manish Sinha Oct 4 '11 at 6:05
    
I've already tried it.The problem is that Flash works with Firefox, but not Epiphany. I've manually tried adding the Libflashplayer.so file to plugins for Epiphany, but it still does not work. can u suggest any other way ? –  Jigar.Shah Oct 4 '11 at 6:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.