Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've upgraded from 11.04 to 11.10 but the ability to tap with three fingers on the touchpad to achieve a middle mouse click has disappeared. When a mouse is plugged in the middle button click works exactly as expected.

I've tried similar approaches to: Swapping the double and triple finger tap actions on trackpad and using $ gsettings set org.gnome.settings-daemon.peripherals.mouse middle-button-enabled true but still nothing works.

I'm using an asus ul-30a which is typically well supported under linux. I'm using gnome-shell but the problem also occurs when using unity.

Could anyone advise how to fix the triple tap please?

EDIT: I've also tried installing the kde package synaptiks and setting the button functions and this also has no effect

share|improve this question
    
See bug: bugs.launchpad.net/utouch/+bug/754000 –  kilaka Feb 22 '12 at 7:52
    
Also see bug 840509 –  Richard Hansen Apr 28 '12 at 4:54
add comment

3 Answers

This shows how to restore middle mouse button emulation by simultaneously clicking with both buttons.

share|improve this answer
    
I can already do this without any changes and that only works in 11.04 not 11.10. –  chemicaloliver Oct 4 '11 at 6:20
    
oh. no other ideas :( –  Jakob Weisblat Oct 7 '11 at 1:54
add comment

Just found an amazing thing:

Taping on the top right corner of the touchpad is like clicking the middle mouse button. I know it's not the same as the triple click and position accuracy is needed :( but it's the closest I could find to triple click.

BTW, clicking on the lower right corner is like clicking the the right mouse button.

share|improve this answer
add comment

Using gnome-shell on 12.04 (precise), I'm able to restore triple tap middle click support by running the following:

synclient TapButton3=2

This command tells the Synaptic driver to make a triple tap gesture (TapButton3) send a middle click (mouse button 2) event.

However, I'm not sure how to best make this change persistent. I could put it in a script as suggested by this blog post, but that approach seems awkward to me. There's got to be a better way.

share|improve this answer
add comment

protected by Community Oct 23 '11 at 18:04

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.