Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After upgrading 11.04 to 11.10 (which was rather bumpy because of a failure with the flash-installer), I can't seem to start hamster-time-tracker.

Output:

user@machine:~$ hamster-time-tracker 
Traceback (most recent call last):
  File "/usr/bin/hamster-time-tracker", line 478, in <module>
    from hamster import i18n
ImportError: cannot import name i18n

Does anyone have any tips on where to start with this issue?

share|improve this question
    
Is your problems solved by restarting? Please add some more comments so that anyone else who think he is having this problem can know that he is also having the exact same problem –  Manish Sinha Oct 7 '11 at 22:06
    
I still get this error when I try to run hamster-time-tracker. I marked the below answer as correct before realising this. –  Michael Robinson Oct 9 '11 at 20:53
    
Does this mean the packaging is broken? –  Manish Sinha Oct 10 '11 at 5:59
    
Maybe, if broken means that after attempting to install it via apt-get it doesn't work. –  Michael Robinson Oct 11 '11 at 21:38
add comment

4 Answers

up vote 2 down vote accepted

The only way I've been able to get hamster going is by building it from source:

git clone git://git.gnome.org/hamster-applet
cd hamster-applet
./waf configure build --prefix=/usr
sudo ./waf install

From Project Hamster

share|improve this answer
add comment

I got this error:

$ ./waf configure build --prefix /usr
Checking for program python              : /usr/bin/python 
Checking for Python version >= 2.4.2     : ok 2.7.2 
Checking for program glib-genmarshal     : /usr/bin/glib-genmarshal 
Checking for program glib-mkenums        : /usr/bin/glib-mkenums 
Checking for program dbus-binding-tool   : /usr/bin/dbus-binding-tool 
Checking for program docbook2man         : not found 
Checking for program xml2po              : /usr/bin/xml2po 
Checking for program xsltproc            : /usr/bin/xsltproc 
Checking for program msgfmt              : /usr/bin/msgfmt 
Checking for program intltool-merge      : /usr/bin/intltool-merge 
Checking for gnome-keybindings variables : Package gnome-keybindings was not found in the pkg-config search path.
Perhaps you should add the directory containing `gnome-keybindings.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gnome-keybindings' found

gnome-keybindings is not a package though. I had to install gnome-control-center-dev:

sudo apt-get install git-core gettext intltool gnome-control-center-dev
git clone git://git.gnome.org/hamster-applet
cd hamster-applet
./waf configure build --prefix=/usr
sudo ./waf install
share|improve this answer
add comment

Purge the package and try re-installing again

As I can see that 2.32.1-0ubuntu5 version is present in Oneiric, so it means something is wrong in your setup.

The list of files does contain these two files

/usr/bin/hamster-time-tracker
/usr/share/pyshared/hamster/i18n.py

Which "might" mean that the package is corrupted

share|improve this answer
add comment

I had this same problem when attempting to use the git version of hamster, and then reverting back to the ubuntu package. I found I had to purge the package, then remove /usr/lib/python2.7/hamster manually, and then reinstall the package.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.