Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an installation of 10.10 that has been working fine since I upgraded. One day I booted it and there was no network connectivity. The network indicator now says "Networking disabled". If I go to System > Administration > Network Tools > Devices the loopback is the default and though Eth0 shows up, if I select it everything is blank in the configuration and there is nothing in the interface statistics. lspci shows

Intel Corporation N10/ICH 7 Family LAN Controller (rev 01)

I have another card handy but would like to learn how to diagnose things like this. For example Is there a software reason that a working card would just stop working? Can the card be so visible but be totally broken? What steps can I try to "Enable" the card and networking or is there something that would point to hardware right off?

UPDATE: It is now working but I would accept the best explanation that might help someone else of why it is working or why I'm still in trouble.
Originally the only thing that showed up in the network indicator was the disabled text and there was no "Enable Networking". Based on another post I tried sudo dhclient eth0 though I have no idea what it does. It returned an ip address and I could browse to specific local ips. Then I rebooted to see what would happen and I had the same original problem so I did dhclient again but this time noticed that "Enable Networking" was now showing up in the indicator so I checked it. This time I rebooted and everything is working fine. But I still don't know why it stopped or why the steps I took worked.

share|improve this question
1  
There are 3 reasons your card might not be working: a) hardware or drivers, b) no good ip configuration, c) network is not enabled. When you did sudo dhclient eth0 your system assumed you network would be enable, would have the name eth0 and that the system would need to get new addresses from the dhcp server (probably a router or something like that) but the flag to enable network was still set to off, so when you rebooted the network went off again. After you enabled you network by clicking "Enable Networking" the system recorded that the interface eth0 was on and was using dhcp. –  Bruno Pereira Oct 3 '11 at 14:38
1  
Probably the sudo dhclient eth0 was not even necessary since your eth0 was using dhcp already, only the interface was turned off. Next time start with ifconfig -a to see the status of your interfaces: if a interface is enabled it will show addresses else it will show addresses. You can start and stop an interface with ifconfig <interface name> up and you can stop it with ifconfig <interface name> donw or in your case ifconfig eth0 up and ifconfig eth0 down. –  Bruno Pereira Oct 3 '11 at 14:47
    
Good info brunopereira81 (and some people do "read this thing") –  Dennis Oct 4 '11 at 13:26
    
I will then try to develop a proper introduction ;) –  Bruno Pereira Oct 4 '11 at 13:58
add comment

3 Answers

up vote 1 down vote accepted

The shortest path is to try known working ethernet card. This advise assumes that your network is configured but not working.

After your update I believe your card is not configured. sudo dhclient eth0 just configures your network interface from DHCP server in your LAN. May be you should try to assign static IP before moving on.

To try static IP you can type:

sudo ifconfig eth0 192.168.0.101/24 and than ping other hosts in your network. Note that instead of 192.168.0.101 you have to specify IP from your LAN not included in DHCP pool.

If you don't know what address to specify run sudo dhclient eth0 again and then ifconfig eth0.

To make this settings persistant edit your /etc/network/interfaces file (see man interfaces for details).

share|improve this answer
    
Combined with brunopereira81's comments this probably has the most useful specific information. –  Dennis Oct 4 '11 at 13:22
add comment

If I read your question correctly, then you are not asking how to fix this problem but how to diagnose networking problems like this.

  1. My advice is read through the documentation.

  2. Browse the links for networking problems on this site and the Ubuntu forums Networking and Wireless section. Notice the problems that people have and the advice given.
  3. Run the commands on a working system (your own) and compare that output from the commands as a means of identifying the differences and working what these indicate the problem is.
  4. From the advice given on the forums note which advice works and use it to develop diagnostic skills.

This is my method. Sometimes I get things right. You may find that you can notice things about the problem that others miss.

share|improve this answer
    
+1 For the links and a good flow chart of the thought process. –  Dennis Oct 4 '11 at 13:20
add comment

Try typing this into a Terminal window:

sudo ifconfig eth0 down
sudo dhclient -r eth0
sudo ifconfig eth0 up
sudo dhclient eth0
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.