Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 11.04, with unity. It's an "inside windows" installation using Wubi, and I've installed on an external USB-HDD.

More and more now, my computer does not shut down properly. It gets stuck on a final black screen, where I can do nothing but do a hard shutdown (press and hold power switch). This is rather painful, as I do recall someone saying that Linux is more sensitive to that than Windows.

Before, it has always worked anyway, no harm, no foul, but today when I booted up, the graphics are different (worse), and I am in Gnome, not Unity. (weird!) I never used Gnome, so I am assuming it is falling back on some default safe-mode.

I've tried the grub startup option labelled "(recovery mode)" before, and that seems to do something, but it does not seem to have fixed the problem. Sometimes, it seems as though it is the uptime that is the culprit, the longer, the worse it is.

Also, but it may be unrelated, from the very first time I installed Ubuntu, I've had some problems with the boot. It goes through windows bootloader, then says something like "error: prefix not found", goes to grub, where it says "error: file not found // error: you need to load the kernel first". Pressing Enter again too fast gives another error, but if you give it 1-2 seconds, then press, Ubuntu boots as normal. I have assumed it is because this external HDD is external, perhaps it is slower, needs a nudge, etc. But it may be related to the problem, who knows.

Update:

Specs as requested in comment. Running Windows XP/Ubuntu 11.04 on a laptop (3-4 years old):

INTEL CORE2DUO T9300 2.5GHZ 800/6M BOX
2 x Kingston 2GB 667MHZ DDR2 NON-ECC CL5 SODIMM

CHIPSET Intel GM965
PROCESSOR   Intel® Core 2 
GRAPHICS CARD   NVIDIA GeForce Go 8600M GT
GRAPHICS CARD MEMORY (MAX)  512 MB
share|improve this question
1  
Rather than a hard shutdown, hold Alt+SysRq and press R-E-I-S-U-B. Also please post your machine specs. –  bcbc Oct 3 '11 at 16:31
    
@bcbc That's a nice trick, thank you. Posted specs. I do not know the specs for the external HDD, other than that it is a WD Elements 1,000 Gb. Has both a USB connection and it's own power supply. –  TLP Oct 3 '11 at 16:42
    
what wireless card do you have? –  bcbc Oct 3 '11 at 18:16
    
Not quite sure. In the textfile I have it says "Intel 300Mbit Wireless", which seems kind of generic to me. Connections says "FIREWIRE,RJ-11,RJ-45,USB 2.0,WLAN," The wireless should be turned off, though, since I use cable internet. There was some hiccup in Windows, when the machine would spontaneously reboot, change the boot device order and try to boot over the wireless. Very strange. I had to fix it in the setup each time. –  TLP Oct 3 '11 at 18:43
    
This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions here. –  jrg Feb 1 '12 at 18:19
add comment

closed as off topic by Marco Ceppi Feb 1 '12 at 19:35

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.