Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After I've installed google-chrome (not chromium), I noticed that it completely overwrote any behaviour set for the default browser, thus resulting in any link clicked in the GNOME environment being opened in Chrome, instead of my actual default browser, Firefox.

Just about any browser I know, Including Opera, Midori, Rekonq, Dillo, Icecat (and a bunch of others) honor the 'default browser' settings, WITHOUT screwing around with global .desktop files.

Even after manually searching for everything possibly related in gconf-editor, I was not able to get rid of this behaviour, and restore firefox as the default browser, so help is very much appreciated.


PS: Please spare me your "why don't you just switch to chrome instead?" - I have my reasons, and this is certainly not the place to discuss them!

share|improve this question
    
a terminal method that is not limited to unity and gnome: askubuntu.com/a/16626/47206 –  cipricus May 28 '13 at 21:39
add comment

1 Answer

up vote 0 down vote accepted

Click on the Unity button (top-left) and type and click on Preferred Applications. In the Internet tab you'll be able to choose the Default Web browser you want.

screenshot_preferred_applications

share|improve this answer
    
(i'm running ubuntu-classic, instead of unity, but the settings are virtually the same) Hah, you beat me to it. Why hasn't that occured to me yet? I feel soo stupid right now... –  hiobs Oct 3 '11 at 4:04
    
@hiobs Happens sometimes, don't feel bad about it :) And thanks for the accept btw –  nitstorm Oct 3 '11 at 4:17
    
hahaha okay :-) and you're very welcome! –  hiobs Oct 3 '11 at 4:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.