Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just upgraded to beta 2 of Oneiric/11.10 and the typing break has gone.

I've gone into the system settings and looked in "Keyboard Layout" and "Keyboard" and can't find anything. Has it just been dropped?

Is there some hidden way to re-enable it?

share|improve this question

6 Answers 6

up vote 14 down vote accepted

11.10

Gnome 3 developers have dropped this from gnome-control-center with a recommendation that it be repackaged and available as a separate application. A launchpad wishlist item was requested.

An alternative in for typing break is workrave. It is now available as a backport:

sudo apt-get install workrave

You need to white-list this application to appear in the Unity indicator-applet. Read this question if you want a more detailed explanation about what to do.

12.04

An enterprising developer has resurrected DrWright for Precise. The package is available from a PPA:

sudo add-apt-repository ppa:drwright/stable
sudo apt-get update
sudo apt-get install drwright

12.10,13.10,14.04

Note, that for 12.10,13.10,14.04 ppa is not up to date, so you have to use precise repositories:

deb http://ppa.launchpad.net/drwright/stable/ubuntu precise main
deb-src http://ppa.launchpad.net/drwright/stable/ubuntu precise main

Find the applet in the Control-Center to launch:

enter image description here

image and source for the information

In a similar manner as for 11.10, workrave is available from the Precise Universe repository if you do not wish to use a PPA.

share|improve this answer
    
Any update for 12.10? –  takeshin Jan 19 '13 at 12:29
    
@takeshin: same as for 12.04 –  Hamish Downer Feb 7 '13 at 10:38
    
@HamishDowner Thanks, works after downgrading to precise repos –  takeshin Feb 7 '13 at 11:11
    
It's not working for 14.04 –  Moreno Aug 11 at 16:37

RSIBreak is a good alternative for Workrave! You can easily get it via Ubuntu Software Center!

It is a KDE application (so it will it install alot of the KDE packages) - however it works OK in Unity.

share|improve this answer
    
RSIBreak is working but with some bugs on 14.04: bugs.launchpad.net/ubuntu/+source/rsibreak #1358846 rsibreak doesnt start on startup #1358849 rsibreak doesnt save settings in actions tab –  rubo77 2 days ago

PPA

deb

Patched for unity and set default to disabled. After you install it, log out / log in. You can find it in gnome control center.

You can convert the drwright rpm to a deb package:

sudo apt-get install alien  
sudo alien -c drwright-3.2.2-1.fc17.i686.rpm  
sudo dpkg -i drwright_3.2.2-2_i386.deb  

Once you install it, typing breaks are configurable via the System Settings menu.

share|improve this answer
    
+1 for my ppa :) –  medigeek Feb 15 '12 at 9:29
1  
Any update for 12.10? –  takeshin Jan 19 '13 at 12:29

I have made Workrave kinda working again in Unity, via a floating xfce4-panel:

http://ubuntuforums.org/showthread.php?p=11886947#post11886947

It is a hack, but I use it now and it works.

share|improve this answer
    
Can you please update your "hack" for 14.04? –  rubo77 2 days ago
    
I couldn't get into the settings of workrave in Unity. but I used this tip: The settings of workrave can be acceced directly from dconf through org.workrave.timers –  rubo77 2 days ago
    
Sorry, I stopped using both Unity and Workrave. –  ayke yesterday

The typing break is back in Ubuntu 14.04, as mate-typing-monitor (part of the MATE desktop). I'm not sure what package it is included in, though. It works fine for me even under XFCE.

share|improve this answer
    
How do you install it then? –  rubo77 2 days ago
    
Well, our company Ubuntu images come with MATE pre-installed, so I haven't done this myself, but I guess you just need to install MATE. It should be a part of the mate-control-center package, so make sure it is installed. It will then appear as /usr/bin/mate-typing-monitor. –  Tuetschek yesterday
    
I installed sudo apt-get install mate-desktop but the typing-monitor is not there yet –  rubo77 yesterday
    
Try installing the mate-control-center package (maybe it is not in the default set of packages that get installed after you run this command). –  Tuetschek 4 hours ago
    
There is also no such package. Do you use ubuntu 14.04? can you find out the package on your system with this help? Or post your output of dpkg -l in pastebin.com? If you have it, you should edit your Answer to include the name, then it would get +1 ;) –  rubo77 1 hour ago

Since it is not in the repository any more, I started to program a new tool in bash with zenity called typebreak.

It is configurable inside the source and does the trick on most Linux systems.

simply download the file from the repository and eventually the file mouse-speed too if you like to slow down the mouse as penalty for not obeying the micro-break

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.