Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to connect to the cloud CouchDB at ubuntu one, but i always get the following error message:

{"error":"unknown_error","reason":"function_clause"}

I tried following requests:

https://couchdb.one.ubuntu.com/u%2F8e4%2F437%2F554355%2Fcontacts/_all_docs https://couchdb.one.ubuntu.com/u%2F8e4%2F437%2F554355%2Fcontacts%2F_all_docs https://couchdb.one.ubuntu.com/u%2F8e4%2F437%2F554355%2Fcontacts/_all_docs

The same error occurs if i try to get the welcome string from the db.

Does anyone has an idea whats going wrong?

share|improve this question
add comment

2 Answers

Therese was a problem with the OAuth header. It was malformed. It worked on other Ubuntu one pages this was confusing me. This site helped me: http://hueniverse.com/2008/10/beginners-guide-to-oauth-part-iv-signing-requests/

share|improve this answer
add comment

Maybe you need a authentication

https://username:password@couchdb.one.ubuntu.com/xxxxxxxxx

share|improve this answer
    
I signed my Request with OAuth. An HTTP authorization isn't required. –  Michael Weimann Oct 1 '11 at 14:12
    
This is really a comment, not an answer to the question. Please use "add comment" to leave feedback for the author. –  tijybba Aug 22 '12 at 15:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.