Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I wanted to try the latest version(trial) of Geomatica, Geomatica 2012 on Ubuntu 11.10 beta. When I tried to run the bin file I got a whole list of dependencies. It also seems that it is a RPM package. Instead of going through each entry manually, is there any easy way to search and install a list of dependencies? Here is the list what I got -

rpm: RPM should not be used directly install RPM packages, use Alien instead!
rpm: However assuming you know what you are doing...
error: Failed dependencies:
glibc >= 2.9 is needed by geomatica-2012-12.0-0.x86_64
libstdc++43 is needed by geomatica-2012-12.0-0.x86_64
libgcc43 is needed by geomatica-2012-12.0-0.x86_64
libgomp43 is needed by geomatica-2012-12.0-0.x86_64
libgfortran43 is needed by geomatica-2012-12.0-0.x86_64
openmotif-libs >= 2.3.1 is needed by geomatica-2012-12.0-0.x86_64
/bin/sh is needed by geomatica-2012-12.0-0.x86_64
libatk-1.0.so.0()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libcairo.so.2()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libcrypto.so.0.9.8()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libcrypt.so.1()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libc.so.6()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libc.so.6(GLIBC_2.2.5)(64bit) is needed by geomatica-2012-12.0-0.x86_64
libc.so.6(GLIBC_2.3.2)(64bit) is needed by geomatica-2012-12.0-0.x86_64
libc.so.6(GLIBC_2.3.4)(64bit) is needed by geomatica-2012-12.0-0.x86_64
libc.so.6(GLIBC_2.3)(64bit) is needed by geomatica-2012-12.0-0.x86_64
libc.so.6(GLIBC_2.7)(64bit) is needed by geomatica-2012-12.0-0.x86_64
libdl.so.2()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libdl.so.2(GLIBC_2.2.5)(64bit) is needed by geomatica-2012-12.0-0.x86_64
libexpat.so.1()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libfontconfig.so.1()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libgcc_s.so.1()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by geomatica-2012-12.0-0.x86_64
libgcc_s.so.1(GCC_4.0.0)(64bit) is needed by geomatica-2012-12.0-0.x86_64
libgdk_pixbuf-2.0.so.0()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libgdk-x11-2.0.so.0()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libgd.so.2()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libgfortran.so.3()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libgfortran.so.3(GFORTRAN_1.0)(64bit) is needed by geomatica-2012-12.0-0.x86_64
libgio-2.0.so.0()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libglib-2.0.so.0()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libGL.so.1()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libgmodule-2.0.so.0()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libgobject-2.0.so.0()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libgomp.so.1()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libgomp.so.1(GOMP_1.0)(64bit) is needed by geomatica-2012-12.0-0.x86_64
libgomp.so.1(OMP_1.0)(64bit) is needed by geomatica-2012-12.0-0.x86_64
libgthread-2.0.so.0()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libgtk-x11-2.0.so.0()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libjpeg.so.62()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libm.so.6()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libm.so.6(GLIBC_2.2.5)(64bit) is needed by geomatica-2012-12.0-0.x86_64
libnsl.so.1()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libpango-1.0.so.0()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libpangocairo-1.0.so.0()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libpangoft2-1.0.so.0()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libpng12.so.0()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libpng12.so.0(PNG12_0)(64bit) is needed by geomatica-2012-12.0-0.x86_64
libpthread.so.0()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libpthread.so.0(GLIBC_2.2.5)(64bit) is needed by geomatica-2012-12.0-0.x86_64
libpthread.so.0(GLIBC_2.3.2)(64bit) is needed by geomatica-2012-12.0-0.x86_64
libpthread.so.0(GLIBC_2.3.4)(64bit) is needed by geomatica-2012-12.0-0.x86_64
libpython2.6.so.1.0()(64bit) is needed by geomatica-2012-12.0-0.x86_64
librt.so.1()(64bit) is needed by geomatica-2012-12.0-0.x86_64
librt.so.1(GLIBC_2.2.5)(64bit) is needed by geomatica-2012-12.0-0.x86_64
libSM.so.6()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libssl.so.0.9.8()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libstdc++.so.6()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libstdc++.so.6(CXXABI_1.3.1)(64bit) is needed by geomatica-2012-12.0-0.x86_64
libstdc++.so.6(CXXABI_1.3)(64bit) is needed by geomatica-2012-12.0-0.x86_64
libstdc++.so.6(GLIBCXX_3.4)(64bit) is needed by geomatica-2012-12.0-0.x86_64
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) is needed by geomatica-2012-12.0-0.x86_64
libtiff.so.3()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libutil.so.1()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libX11.so.6()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libXinerama.so.1()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libXm.so.4()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libXt.so.6()(64bit) is needed by geomatica-2012-12.0-0.x86_64
libXxf86vm.so.1()(64bit) is needed by geomatica-2012-12.0-0.x86_64
share|improve this question

2 Answers 2

up vote 2 down vote accepted

Ubuntu uses the debian (.deb) packaging mechanism.

A .rpm is a different packaging mechanism called RPM Package Manager - you cannot install a .rpm directly on a .deb based distro - and visa versa.

Either download the sources themselves and compile the software or look for a .deb package which you can install.

For some simple .rpm packages you can use "alien"

sudo alien -d -i [package_name].rpm

This could create a .deb file which you may be able to install. However, this is very hit-and-miss - strongly suggest find the .deb or compile from source.

share|improve this answer
    
What you say is true about .rpm packages. But this is a commercial application which is provided in .bin form. I can't expect them to give .deb or source for it! –  Chethan S. Oct 1 '11 at 10:24
    
Then you dont have have many choices - try alien otherwise contact the vendor and request that they release a version for ubuntu. –  fossfreedom Oct 1 '11 at 10:29
    
Just a small revise, RPM is not called as Resource Package Mechanism, it is a recursive acronym: RPM Package Manager. –  heartsmagic Nov 11 '11 at 13:43
    
... many thanks...! –  fossfreedom Nov 11 '11 at 15:44

Read the Install.pdf that came with Geomatica carefully - especially near the bottom where it discusses the use of the LD_LIBRARY_PATH environment variable. Once you set up as they discuss, and possible download a legacy OpenSSl-v0.9.8 that suplies some of the OLD stuff they use (also OpenMotif - old version), it may just work.

I use Centos 6.0 on a AMD 64 bit system. works but is clunky and slow compared to the Win7 version. Shame on them!

share|improve this answer
1  
You are able to use it as CentOS natively uses RPM packaging. –  Chethan S. Mar 23 '12 at 2:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.