Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have been using Oneiric since beta 1 release. After yesterday's update unity has stopped appearing. I did update a few minutes back too, but still it's not working with my default account. Surprisingly it works with 'Guest' login and a new administrator type account which I am using now. In my default account I am greeted with a blank screen. Going to tty1 and typing unity or unity --reset did not make any difference.

share|improve this question
For me, Unity start working for updated user profile after deletion of ~/.gconf/compiz-1 and ~/.gconf/compizconfig-1 – Extender Oct 2 '11 at 15:44
Do you mean ~/.gconf/apps/compiz-1 and ~/.gconf/apps/compizconfig-1 ? – Dan Taylor Oct 22 '11 at 4:13
Update: Yes. With the appropriate path, this DOES fix the blank screen problem. Thank you Extender. FYI: This was a problem with ubuntu 11.10 logging in as Unity (3D). Before this, I had to login using unity 2d. And yes, the unity plugin must also be enabled. – Dan Taylor Oct 22 '11 at 4:23
up vote 2 down vote accepted

I might have been in the same situation. What had happened for me yesterday (after updating) is that for some reason the Unity plugin was disabled due to keyboard shortcut conflicts. I tried unity --reset, but it didn't help.

So here's one thing you could check:

  1. Enter CCSM (CompizConfig Settings Manager) 1a. If you don't have it, run sudo apt-get install compizconfig-settings-manager
  2. Check that Unity plugin is enabled.
  3. If not, try to enable it. If it asks a lot of questions about conflicts, just click on "Turn off ..." on all of them, that means some other plugins use those shortuts, but Unity should have the priority.

Not sure you're in the same boat, but might be worth checking.

-EDIT- I misread, I could at least enter the desktop with no unity and launch a terminal with CTRL + ALT + T. If you just get a blank screen then this might be something else.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.