Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Ubuntu 11.10 and then after that, I upgraded my Lubuntu 10.10 to 11.04. The grub2 initiated through the installation overwrote the grub written by Ubuntu. After that, I can't find any boot entries leading to Ubuntu or Windows 7 in the grub menu. How do I recover the grub2 which has all the menus?

Here are the outputs for update-grub and fdisk -l

update-grub :

Found linux image: /boot/vmlinuz-2.6.38-11-generic
Found initrd image: /boot/initrd.img-2.6.38-11-generic
Found linux image: /boot/vmlinuz-2.6.35-22-generic
Found initrd image: /boot/initrd.img-2.6.35-22-generic
Found memtest86+ image: /boot/memtest86+.bin

fdisk -l

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x65728979

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1          13      102400   de  Dell Utility
Partition 1 does not end on cylinder boundary.
/dev/sda2   *          13        1288    10240000    7  HPFS/NTFS
/dev/sda3            1288        8937    61440000    7  HPFS/NTFS
/dev/sda4            8937       38914   240786311    f  W95 Ext'd (LBA)
/dev/sda5            8937       33999   201311607+   7  HPFS/NTFS
/dev/sda6           36442       38805    18979840   83  Linux
/dev/sda7           38805       38914      872448   82  Linux swap / Solaris
/dev/sda8           33999       36334    18751488   83  Linux
/dev/sda9           36334       36442      863232   82  Linux swap / Solaris
Partition table entries are not in disk order
share|improve this question
The next time you are here looking to overwrite Lubuntu's grub, do this: sudo grub-install /dev/sda And don't forget to thank Takkat and aking1012. – jokerdino May 1 '12 at 13:14
up vote 4 down vote accepted

Just boot into Lubuntu and from the command line:


Check the output from the command and make sure all your distros are there.
If not then try:

grub-install /dev/sda

More information can be found in this dual-booting guide

share|improve this answer
Thanks for your time. After posting this question, I found a similar question which led me to install os-prober. After installing it and finding that all the menus are available in the grub, I removed the 30_os_prober something file from the /etc/grub.d directly. Now, if I try to reinstall the os-prober, it still doesn't provide the desirable result. I tried your solution but it doesn't list all of the distros. Thanks again! – jokerdino Oct 1 '11 at 4:17
I don't know what I did but somehow all the distros are suddenly available in the grub boot menu. Just the way I like. Thanks everyone for your time. :) – jokerdino Oct 1 '11 at 4:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.