Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed a wubi on my optiplex gx 620 recently on top of a windows xp. But after using it for about two weeks, I notice that the software update can never be carried out again. Every time I log in the system reminds me to do updates, but when I press the update button it flashes out a temporary message box (for about half a second) saying there is some authentication error (I can't get the complete message since it's too fast). This didn't bother me too much until today when I want to install foreign language support. The same flash message box appeared again and the installation cannot be done. After waiting for about 5 minutes a message box pops out saying "time out most likely the daemon died". I can give more details but I thought this might be a generic problem with wubi installation?

updates: after following the advice of fossfreedom, I think the upgrading is up and running! Before I only typed in sudo apt-get update, but I guess it's important to do upgrade as well! Thanks a lot!

My only lingering concern is how to do this upgrading automatically outside terminal. It seems there should be a way to enter password in a GUI? It would also be nice because sometimes I don't know the name of a particular software (like a language package) so it's easier to just upgrade in a GUI.

share|improve this question

migrated from Sep 30 '11 at 18:06

This question came from our site for professional and enthusiast programmers.

belongs on ubuntu – Daniel A. White Sep 30 '11 at 17:15
please can you run in a terminal sudo apt-get update && sudo apt-get upgrade - post the results of the output into your question. – fossfreedom Sep 30 '11 at 18:17
@user - Hi and welcome to AskUbuntu - can I suggest you register with this stackoverflow site with your current credentials. – fossfreedom Sep 30 '11 at 19:08
Hi @fossfreedom, thank you for the suggestion. I am now registered. Could you take a look at my updated question as well? Thanks! – user48225 Sep 30 '11 at 19:25

Open the dash and type update manager will display your Update Manager. Click the Settings button (bottom left)

enter image description here

You can set the frequency of updates and well as what you update as shown by the arrows in the picture.

Open the dash again and type startup applications

enter image description here

Make sure that update notifier is checked - this will then automatically run update manager according to your update frequency defined above.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.