Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ok here is a thing i want use Ubuntu as media center with my 42" Plasma TV connected with HDMI

first i installed windows and all worked fine HDMI port worked fine with movies but u know windows sometimes it works sometimes it updates in middle of movie and then restart itself or network just decide to not work or there is no sound on HDMI but when u restart few times hey there is sound to

So i decide to install Ubuntu 11.04 64bit and be happy cause i never have problems with Ubuntu and when I installed all and connected my PC to TV using HDMI but when i do that Ubuntu wont boot nor display image. If HDMI is off it boots normaly and i can access it remotely with SSH. When i plug in back HDMI still no display? so i search around google how to make it work and there is few articles about EDID so i guess i need that EDID for my TV and put it inside xorg.conf but i cant get my EDID couse ubuntu wont boot if there is HDMI

So im wondering what i can do to fix that first step thats booting with HDMI ?
And how to get that EDID and display picture on tv with sound trougt HDMI if anyone can help ??

i have
MSI K9NGM3-FIH - aka ( MS-7349VER:1.1 ) Motherboard with HDMI on board here is link!
PDP-427XD Pioneer plasma TV here is link!
I think other specs are not important couse all works just TV, Ubuntu and HDMI are not frendly

share|improve this question
    
Plug in a VGA monitor in parallel to your display - it should boot then and let you analyse more. –  aquaherd Sep 30 '11 at 20:18
add comment

1 Answer 1

I plugged in VGA monitor and then i sow that Ubuntu is booting in console mode without GUI also i cant see anything:

enter image description here

I can login but i cant see nothing and when i unplug hdmi and restart boots normaly to desktop and i plug in HDMI and run in terminal with this command

neone@MediaCenter:~$ sudo get-edid | sudo parse-edid
parse-edid: parse-edid version 2.0.0
get-edid: get-edid version 2.0.0

    Performing real mode VBE call
    Interrupt 0x10 ax=0x4f00 bx=0x0 cx=0x0
    Function supported
    Call successful

    VBE version 300
    VBE string at 0x11100 "NVIDIA"

VBE/DDC service about to be called
    Report DDC capabilities

    Performing real mode VBE call
    Interrupt 0x10 ax=0x4f15 bx=0x0 cx=0x0
    Function supported
    Call successful

    Monitor and video card combination does not support DDC1 transfers
    Monitor and video card combination does not support DDC2 transfers
    0 seconds per 128 byte EDID block transfer
    Screen is not blanked during DDC transfer

Reading next EDID block

VBE/DDC service about to be called
    Read EDID

    Performing real mode VBE call
    Interrupt 0x10 ax=0x4f15 bx=0x1 cx=0x0
    Function supported
    Call failed

The EDID data should not be trusted as the VBE call failed
Error: output block unchanged
parse-edid: IO error reading EDID
neone@MediaCenter:~$ 

is there any other way to get edid and why this happen when i plug in HDMI ????

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.