Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use Gnome and Xfce sessions, but whereas in Gnome I have application shortcuts on the panel, in Xfce I prefer having application launchers on the desktop.

I don't need the desktop launcher in Gnome, so I would like to have them hidden in the Ubuntu Classic session. I tried to append the OnlyShowIn=XFCE option at the bottom of the .desktop files in the Desktop folder, but to no avail.

share|improve this question
    
It works for me –  enzotib Sep 30 '11 at 16:13

1 Answer 1

up vote 0 down vote accepted

The OnlyShowIn tag controls what launchers appear in menus. The launchers themselves (eg 'firefox.desktop') are just files and will appear in their relevant folders regardless of your desktop environment.

To prevent Nautilus from showing files (and thus, launchers) on the GNOME Desktop:

  1. Launch gconf-editor
  2. Navigate to apps > nautilus > preferences
  3. Untick the show_desktop option
share|improve this answer
    
Not true, it works also with show_desktop set true, though needing a nautilus refresh. –  enzotib Oct 5 '11 at 12:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.