Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've run across a weird issue that I was wondering if anyone had seen before. We run a custom version of Ubuntu 10.04 at work and we've been testing some software that uses webcams recently, which 90% of the time works great but we've had a crash event on two separate pieces of hardware with quite different configurations which basically disables the in-built webcam completely.

I've run through checking lsmod, lsusb, dmesg to see if the device or module appears at all (it doesn't), the block reference in /dev disappears completely and for all intensive purposes the webcam is gone. We then ran through a series of tests culminating in a fresh install of Ubuntu 10.04 LTS with no tweaks which once again couldn't find the webcam, the only way we could get it to appear was to install XP, autodetect it, then swap back into Ubuntu which would then acknowledge it.

My initial thoughts run to something to do with power control (I used to have an Aspire One, and if you used the Wifi power off switch a similar thing would happen), but I have no idea whether I'm on the right track or where to start looking to try resolve that one.

Any thoughts about what could cause a device to become apparently 'powered off' from the USB bus, and why it would require Windows would be much appreciated.

Additional: We can actually get the cam to come back up if the machine has function keys for enable/disable webcam, but we've still not isolated what triggers it.

share|improve this question

closed as off-topic by bain, Eric Carvalho, Mateo, Sneetsher, Lekensteyn Jun 30 at 17:00

This question appears to be off-topic. The users who voted to close gave these specific reasons:

If this question can be reworded to fit the rules in the help center, please edit the question.

    
I wouldnt dare to try and understand this - however these answers look promising - especially this one - suggest give this/these a try. stackoverflow.com/questions/1163824/… –  fossfreedom Oct 31 '11 at 20:29
    
I'll take a look, thank you. I kind of sort of need to understand how it's occurring to try and avoid it, my working theory at the moment is something is triggering a call to ACPI to disable the hardware for some reason, but I've not worked out where or what yet. –  Nicholas Smith Nov 1 '11 at 9:42
    
it "shouldn't" happen, but I've seen hardware with the exact same hardware id cause issues before. For example a laptop with a webcam built-in(and simply tacked on to a USB hub) having issues when another of the same is plugged in. I never resolved it. With the billable rate at the time, it was cheaper to get a different kind of webcam. –  hbdgaf Nov 7 '11 at 4:17
    
Well the interesting thing is it's listed in lsusb as a separate device, I thought it was just hanging off a hub but it looks like the manufacturer went a different route on it. The main issue for us is we can get the bug to replicate but we know it's there, and we've got a good chunk of the machines in the field. –  Nicholas Smith Nov 7 '11 at 9:45

1 Answer 1

It could be although I don't know for sure that Ubuntu 10.04 automatically disables the USB port and Windows re-enables it. Check the BIOS and see if it happens again before doing anything with Windows. Generally to get to BIOS you have to press F12 when the computer first turns on.

Jake

share|improve this answer
    
We've double checked it, interestingly when it occurs we can use the keyboard enable/disable webcam function keys to bring it back up. –  Nicholas Smith Dec 13 '11 at 9:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.