Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My ubuntu (version 10.10 I think) is stuck in loop at the login screen. Looks like it could be a resolution issue. - I have an nvidia graphics card (gs 8400). I previously had it connected to a 19" monitor however disconnected mid session and since then the issue has persisted. I tried uninstalling the gdm package and reinstalling and running an apt-get update however the login loop still there.

Is there another way I can reset the resolution settings to fix this looping issue?

I can get into the desktop by going through the rescue mode and using startx but its not a solution.

share|improve this question
add comment

7 Answers 7

You can edit /etc/X11/xorg.conf by hand

Or you can use nvidia xconfig if you have the proprietary driver sudo nvidia-xconfig

Or sudo dpkg-reconfigure -phigh xserver-xorg

ref: http://doc.ubuntu-fr.org/xorg

share|improve this answer
    
thanks.ill try this later when i get home from work. is there a command which will reset back to the best fit settings for my monitor or do have to manually change the resolution values? –  linuxlewis Sep 30 '11 at 8:53
    
sudo dpkg-reconfigure -phigh xserver-xorg will reset back to default. –  jflaflamme Sep 30 '11 at 12:45
add comment
  • Switch to the text console Ctrl-Alt-F1
  • Login with your username / password
  • Check for errors, write them down word for word. Did you enter your home directory?
  • Check the output for ls -l /home. Does it say drwx at the start of the line, notice especially the w?
  • Check for nearly full filesystems df -h
  • Type exit
  • Switch to the graphics console Ctrl-Alt-F7
  • If you had any errors on the text console, add them to your question.
share|improve this answer
    
Where does the 32768 come from? Does sudo dpkg --configure -a; sudo apt-get update; sudo apt-get-upgrade get you any further? –  jippie Apr 30 '12 at 18:02
    
It did get an update for xorg-server, but no luck. –  PhilG Apr 30 '12 at 20:48
add comment

If it's an issue with your user account - you can try following the below procedure.

In this case, follow the password reset procedure;

https://help.ubuntu.com/community/LostPassword

Login as root, and see if your user account exists. (You could ls -la /home/ and see if your files are owned by an account name or just an ID number).

If it is only owned by something like 501 or some ID number, you may need to recreate your user account.

On the other hand, if your home directory is inaccessible even to your root account it may be encrypted and there is not much we can do.

You may follow the steps detailed here and see if you can recover your home directory encryption phrase.

https://help.ubuntu.com/community/EncryptedPrivateDirectory#Recovering_Your_Mount_Passphrase

share|improve this answer
    
Recovered encryption phrase, uninstalled ecryptfs-utils, no luck, still experiencing same problem. –  PhilG May 1 '12 at 0:28
    
My user id (via id command) comes out to 1000. Root comes out to 0. –  PhilG May 1 '12 at 2:10
add comment

OK, so I found a work around. I uninstalled lightdm, gdm, and mate. I reinstalled gdm, to no avail, so uninstalled it, reinstalled lightdm. I then deleted my phil2 account, created another account, moved my home files from my primary account to the newly created account, and using sudo chown -hR /PATHNAME I now have access to all my files.

While not a true solution to this problem, it does work. I was close to "nuking and paving" my hard drive (i.e., deleting partitions and files then reinstalling).

We'll see how well this goes.

share|improve this answer
add comment

Tricky and frustrating. But here is the fix....Use Ctrl-Alt F7 to get to the desktop...you will see that the Update is waiting for you to answer a graphics upgrade question. I chose the lightdm option.

Then it proceeds with your update. Fixed.

(I had to turn to my buddy in the next cube for help with this one.)

share|improve this answer
add comment

What I did wrong was to try to use xstart, in error. When using xstart .Xauthority is created in user directory. I've had problems with this on other systems, deleting the file(s) solved the problem for me.

share|improve this answer
    
Thanks for your contribution and welcome to AU. Please focus on how the problem is solved. I think formatting your answer (paragragphs) should be enough. –  Mateng Nov 19 '12 at 21:34
add comment

Check if you have your files in your /home/username directory. If you just have two files, one named blah-blah.desktop and a README, open the readme file (using nano, or simply read it using cat) and follow the instructions. Of course, do that in a terminal (pressing Ctrl-Alt-F1 in the login screen)

share|improve this answer
add comment

protected by Braiam Jan 18 at 15:55

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.