Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Ubuntu 10.04 on a Macbook Pro 5.5. Everything has worked nearly flawlessly, with the exception of the wireless.

I cannot describe how poor the proprietary Broadcom driver is.

I'm unable to connect to about half the wifi hotspots I encounter. After I suspend, I can't connect to 99% of hotspots I encounter. I compare this to my Android smartphone, whose wifi is able to connect to 100% of hotspots that my Macbook can't connect to. I've found only after a fresh restart is my wifi at all reliable.

Does anyone know of, or have experience with alternative Broadcom WIFI drivers? The proprietary one is unfortunately the recommended choice in all the wiki docs I've found concerning Macbooks.

EDIT: I tried the procedure outlined here but it did not work. It consisted of:

sudo apt-get install broadcom-sta-common broadcom-sta-source
sudo m-a a-i broadcom-sta
sudo /etc/init.d/networking restart
sudo service network-manager restart
sudo shutdown -r now

But after wireless devices listed...

EDIT: Looking in /etc/modprobe.d, I found the following files that appear to block blacklist the b43 module. The file blacklist-bcm43.conf comments that's it autogenerated by the bcmwl package, but I don't know where the others are coming from (I might have added the myself a long time ago).

share|improve this question
Please please update to 11.10 - 10.04 is way tooooo old. – cweiske Oct 14 '11 at 22:31
up vote 1 down vote accepted

I just had a similar problem, these were my steps to fix it

Remove the STA driver from Additional Drivers I typed in broadcom in ubuntu software center, clicked and uninstalled Have your laptop attached to LAN Install b43 (installer package for firmware for b43) (searched b43 and found it) restart machine

$sudo halt - p

login restart network

$sudo /etc/init.d/networking restart

check if its there


I see wlan0 but its unavailable

$sudo ifconfig wlan0 up

looks like its working but no networks available

restart again and wireless networks come to view. fixed

Try it and let me know

share|improve this answer
The only b43 package available for 10.04 is "b43-fwcutter". Is that the one you're referring to? – Cerin Oct 14 '11 at 17:23
Your procedure does not appear to work. nm-tool shows no wireless interface. – Cerin Oct 14 '11 at 17:46
yeah, it was b43-fwcutter was what I was referring to. – iSimply Oct 15 '11 at 16:09
I had seen somewhere, if that didn't work, there was a blacklist in a .conf file that needed to be commented out. I'll see if I can find the web site. – iSimply Oct 15 '11 at 16:10
put a # in front of the line "blacklist bcm43xx" in blacklist.conf. I'm not sure about the other two files. – iSimply Oct 15 '11 at 16:30

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.