Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running a Dell XPS L502X, one of those hybrid graphics models that don't yet "just work" on Linux :( When I installed Ubuntu (Natty) I just went ahead and accepted whatever options I was given, including installing the current NVidia drivers.

Additional Drivers reports the driver as the current version, recommended, required for Unity, activated, but not currently in use. However, I can't actually run Unity, so I'm currently running with Unity 2D. Ubuntu has not detected the driver as being obsolete, but I get the following when running /usr/lib/nux/unity_support_test -p :

Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Error: unable to create the OpenGL context

When I start the "NVIDIA X Server Settings" application, I get the following message: "You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root, and restart the X server."

I've since been told that on these models specifically you shouldn't install or activate the NVidia driver. Is this true, and why?

If it is true, should I uninstall the driver, and what benefits will this give me? If I uninstall it, what should I switch to, if anything? How do I uninstall it?

Otherwise, is it safe to activate it? In which case do I just run sudo nvidia-xconfig?

My goal here is to either:

  • run Unity just like the other kids
    • by enabling the NVidia driver if this is required
    • or, by doing something else
      • and, uninstall the NVidia driver, if this is advisable (whether or not it is required)
  • continue running Unity 2D if Unity is impossible on my machine
    • by doing nothing (leave the system as-is)
      • and, uninstall the NVidia driver, if this is advisable

My goal is not (yet) to:

  • get hybrid graphics working (for example, by install Bumblebee) - it seems to me that support for this is still in development on the Linux platform, so I'll let others experiment :)
  • disable either the Intel or NVidia card (I want to get Unity working "the right way" first)
share|improve this question
    
possible duplicate of How well do laptops with Nvidia Optimus work? –  Javier Rivera Sep 29 '11 at 14:57
add comment

3 Answers

up vote 4 down vote accepted

The intel video card is perfectly capable of running desktop effects, so Unity should work as well. You cannot use the nvidia card directly (as you may already have noticed) because your notebook is an Optimus laptop (see also How well do laptops with Nvidia Optimus work? on that).

If you do not run programs that heavily rely on the graphics card, just stick to the Intel iGPU to save power as well. As a developer of Bumblebee, I can tell that work is in progress to get automatic power management working which would disable the nvidia card to save even more power. However, this feature is not mature yet so I'd not recommend it to regular or power users for the reason that you'll need some understanding of ACPI.

share|improve this answer
    
thanks for the info, I've made my question a bit more meaningful to someone else based on your response (I hope) - so it seems that I can't actually use the NVidia card at all without Bumblebee/switcheroo etc, so enabling the NVidia card won't work - does this mean I ought to uninstall the driver? (alternatively, I could keep it for when I do eventually install Bumblebee/etc) - what do you make of the unity_support_test error I'm getting? could it be a bug or something else beyond the scope of this question? - thanks for all the info so far! –  d3vid Oct 12 '11 at 5:49
1  
Since your nvidia driver does not work at all and breaks OpenGL capabilities of the Intel card, you may want to remove the nvidia driver or install Bumblebee which takes care of setting the default OpenGL driver to Mesa. The error from unity_support_test is cryptic, but it just means that the OpenGL capabilities are not found (because the nvidia driver broke it). Either install Bumblebee or uninstall the driver or run (for Ubuntu Natty and before) sudo update-alternatives --set gl_conf /usr/lib/mesa/ld.so.conf –  Lekensteyn Oct 12 '11 at 12:48
    
thanks, that's exactly what I was looking for! –  d3vid Oct 13 '11 at 9:33
add comment

I actually installed switcheroo on my ASUS and wrote a /etc/init.d script (with start, stop, status and help options) which I have symlinked as S--- or K--- from the different /etc/rcX.d directories. You need to load the nouveau drivers before disabling the NVIDIA and you need to reenable the NVIDIA before unloading the nouveau drivers in order to have a seemless boot/shutdown process. And for the rest, I do have the same requirements as you and the IntelHD Ironlake I have is running my compiz+GNOME2 environment quite well. I'm still on 10.10, because I didn't get to love Unity enough ;-)

share|improve this answer
    
Update: I have now included acpi_osi=Linux to the grub command line in /etc/default/grub (GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux") and removed all the asus-switcheroo magic. My DSDT completely disables the NVidia processor by doing so, I get more battery life and less problems in boot/shutdown –  Pedro A. Oct 8 '11 at 5:30
add comment

To run Unity like the other kids you might have to disable the nvidia card in the bios (if possible). This will also save battery life. If you cannot disable nvidia in bios, you might want to install bumblebee anyway because it will help you to run 3D graphics with the intel card too.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.