Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I found an old post saying that WPA2 is not supported by the RTxxx (Ralink) drivers.

  • Is this statement still accurate for 10.04 LTS server?
  • Is ndiswrapper being used automatically instead?

Case specific info:

I'm attempting to use a RaLink RT2760. This card auto-configured beautifully under Ubuntu 11.04, but I have a need for 10.04 LTS server, so I'm re-imaging.

$ iwconfig
wlan0 RT2860 Wireless  ESSID:""  Nickname:"RT2860STA"
      Mode:Auto  Frequency=2.412 GHz  Access Point: Not-Associated
      Bit Rate: 1 Mb/s
      RTS thr:off    Fragment thr:off
      Link Quality=10/100  Signal level:0 dBm  Noise level:-87 dBm
      Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
      Tx excessive retries:0  Invalid misc: 0  Missed beacon:0

makes it appear that everything is working properly, yet

$ iwlist scan
wlan0    No scan results

There are 8 discoverable networks in range.

share|improve this question
add comment

2 Answers

A few of suggestions:

suggestion 1

Try installing the wireless backports package to see if this resolves your issue.

sudo apt-get install linux-backports-modules-wireless-lucid-generic 

suggestion 2

Possibly (though probably unlikely) this is a firmware issue and you need the non-free firmware package from the multiverse repo

enable the multiverse repo is /etc/apt/sources.list

sudo apt-get install linux-firmware-nonfree 

suggestion 3

10.04 now ships as an optional repository install, the 2.6.38 kernel that is used in 11.04 as well.

sudo apt-get install linux-image-generic-lts-backport-natty linux-headers-generic-lts-backport-natty
share|improve this answer
add comment

Well, I don't know for that particular chipset or that particular release, but my Ralink 3062 definitely supports WPA2 on Ubuntu 11.04 and 11.10. I had to download my driver directly from Ralink, though (rt2860 / rt3562sta).

To see the driver that is actually in use, run sudo lspci -v.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.