Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Im having troubles with pulseaudio. I have my home folder on an ntfs partition because i have dual boot on my netbook, and i need to share my home folder with windows. I used to have debian, and i had no problem with that, but now I moved to ubuntu 11.04 and I cant control audio with hardware keys (fn+f12).

Ive setted all the permissions and group owning to my user and group by properly mounting the partition via fstab:

/dev/sda7 /home ntfs-3g utf8,umask=000,uid=1000,gid=1000 0 1

but, when i try running pulseaudio --start, i get the following output:

E: core-util.c: Failed to create secure directory: Permission denied
W: lock-autospawn.c: Cannot access autospawn lock.
E: main.c: Failed to acquire autospawn lock

Audio is working good. I can hear everything good, but i cant control sound volume through unity bar's controls, neither through hardware keys...

Any help would be really appreciated! thanks! =)

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

It isn't a good idea to have your home folder on an ntfs partition, since the ntfs file system lacks some features that have been around since the earliest installments of unix.

In rough detail every program that needs to create a unix-domain-socket (a file-system based fifo or pipe) in your home folder will utterly fail on ntfs. You can hunt down each of these programs and check if it is possible to configure them to use some other folder instead, but this is most likely a tedious task.

What you can do however is to mount the ntfs partition inside your home folder or hardlink any subfolder of it to have every music, video and document in it and happily share it with windows.

Your fstab for example may look like this (assuming Windows 7)

/dev/sda7 /media/seven ntfs-3g utf8,umask=000,uid=1000,gid=1000 0 0
/media/seven/users/throoze/Music /home/throoze/Music none rw,bind 0 0

This way, you get rid of a lot of cruft which isn't any good and is easily tampered in each other system.

Note that the last '1' in your fstab should be substituted with '0', since fsck.ntfs is mostly useless.

share|improve this answer
    
Wow! that's a workaround i didn't even think about!!! I've not tried it yet, but surely it will work... Thanks a lot! A couple of questions: Mounting folders like this creates a hard link? and, would you recommend a hard link over a symlink in this case? why? –  Throoze Sep 30 '11 at 4:04
    
You can't hard link from one file system to another, only soft links will work. Hard links to folders are disabled under linux for fear of loops. But you can mount some folder to some other place instead. –  aquaherd Sep 30 '11 at 20:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.