Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I get the following pieces of information at the startup, takes about 3 to 5 minutes, while normally about 1 minute:

Waiting network configuration
Booting system without full network configuration

I found after googling that I should change /etc/networks/interface. I commented out everything there but the problem remains:

# auto lo
# iface lo inet loopback

# auto eth0
# iface eth0 inet dhcp
# address 192.168.0.2
# netmask 255.255.255.0
# gateway 192.168.0.1
# broadcast 192.168.0.255

How can you make the startup of Ubuntu 11.10 faster?

share|improve this question
3  
I do not understand this behavior. I do not want to change my interfaces file every time I go home. There are situations where I simply have no network OR I use wicd AFTER logging in. For me as a laptop owner that means waiting 2 senceless minutes. Twice every day. Besides: I configured all interfaces to be static. No way. –  user32333 Nov 4 '11 at 22:12
2  
@jrg It is not a code problem, it a desing problem. Can I file a bug about such a problem? –  Masi Nov 4 '11 at 22:53
1  
Yes, you can. Just make a note that it is a design bug. :) –  jrg Nov 5 '11 at 0:33
    
@jrg What should be the status of the bug? - I selected xorg as the package, since needed to select something. I put the status to invalid to it, since it is not really about it. - It is about the design. Can people understand now that the status of the bug is not declined, but only for the package xorg? –  Masi Nov 5 '11 at 14:04
    
@Masi Hm, not sure. –  jrg Nov 5 '11 at 14:21

6 Answers 6

up vote 31 down vote accepted

First off, this is a new behavior, documented in the 11.10 release notes, that I actually developed together with Scott Moser as an effort to make server boot more reliable.

Commenting out lo will mean you have no "local" network capability, which will break some programs when they try to use the network. It will also cause your system to never boot because it is so critical. So leave these two lines:

auto lo
iface lo inet loopback

The bits about eth0 meant that your machine was configured to wait for a dynamic address to be assigned to it before the netowrk is considered "UP". In pre-upstart versions of Ubuntu (8.10 and earlier), the system would have waited up to 60 seconds for this before continuing the boot. When upstart was added, this condition wasn't waited for anymore, because network interfaces that were not always expected to be plugged in are better managed by something like network-manager.

So, if you have a server, you probably want to wait for a dynamic address, otherwise the system will boot without all of its networks available (which it does if it takes more than 2 minutes to get an address). If you have a laptop that you don't always expect to be plugged in to eth0, then configure eth0 in network manager, and remove only those lines from /etc/network/interfaces, which should get rid of your boot delay.

Keep in mind, there's a known bug with VMware and dbus that also causes this message:

https://bugs.launchpad.net/ubuntu/+source/dbus/+bug/811441

share|improve this answer
1  
Masi, sounds like you need to ask a different question. –  SpamapS Oct 19 '11 at 0:24
2  
Sorry, I am a newbie and I still don't understand why the system must wait around 2-4 extra minutes for IP. And the main question is "do I need this one. if I have a laptop and I always use wired and wireless network connections?" –  itun Nov 2 '11 at 10:14
1  
@SpamapS and Scott Moser Please, change the thing back it was. You are hurting Desktop users. I understand your point that you save time in programming things, but please consider if 100 million users lose every day 2 minutes because of such a change. It is a huge cost! Please, branch Ubuntu Server completely different from Ubuntu Desktop. –  Masi Nov 4 '11 at 22:50
4  
upvoting this for awareness BUT as a normal Desktop user I am VERY UNHAPPY that there is no fast boot option for this. Definitely perceived as a degradation from 10.04 to 12.04 upgrade. This problem is compounded by the fact that network manager is unable to directly control settings such as duplex and autoneg, resulting in the need to achieve that via /etc/network/interfaces –  prusswan Feb 6 '12 at 4:17
2  
@SpamapS: While I'm glad you've pondered adding a no wait option, what really needs to be pondered is why Canonical so consistently fails at QA (user for the last 6 years, and I encounter showstopper regressions every release that should have prevented every release). That aside, the server and minimal CDs are widely used for desktop installation because the graphical installer often has issues and/or it's easier getting the minimal CD running on faulty media. It is definitely not safe to assume that because a user is using the alternate or minimal CD they must be installing a server. –  Joseph Garvin Sep 22 '12 at 6:21

You're mixing 2 incompatible ways of assigning an address to a network interface.

iface eth0 inet dhcp

says "send out a DHCPDISCOVER packet to the physical local network, wait for a DHCPOFFER packet from a physically local DHCP server, and get the IP address from it (see http://www.rfc-editor.org/rfc/rfc1531.txt), while the rest of the lines assign values to the interface "manually". It's important that one gets the IP address assignment method right. If there is a DHCP server on your local network, you should use it. To do so, delete the "address", "netmask", "gateway", and "broadcast" lines.

If you're not connected to an "administered" local area network (and don't have a DHCP server), and want to assign the IP address parameters manually, change the first line to:

iface eth0 inet static

and keep the "address", "netmask", "gateway", and "broadcast" lines. See http://www.rfc-editor.org/rfc/rfc5735.txt for details about which IP addresses are available for use. The parameters you have look OK to me.

Read

man 5 interfaces

simply commenting everything out is not the best path to happiness.

share|improve this answer
    
Thank you for your answer! - Why does my Ubuntu work with empty /etc/network/interfaces? - How can you see that it is not working normally or efficiently? –  Masi Sep 28 '11 at 22:00
    
So the last line says: send out a static package to the physical local network, wait for a static package from a physical local network, and get the IP address from it. –  Masi Sep 28 '11 at 22:02
    
I have know [code]iface eth0 inet static address 192.168.0.2 netmask 255.255.255.0 gateway 192.168.0.1 broadcast 192.168.0.255[/code], in my /etc/network/interfaces and the problem still persists: loading a lot. –  Masi Sep 28 '11 at 22:09
    
No. The line with "static" says "Get the IP address from the following lines" no network packets are sent. –  waltinator Sep 28 '11 at 22:23
1  
I think I understand. Because your mobile broadband isn't configured when the boot sequence does its ifconfig -a during startup, you get the timeout. –  waltinator Oct 2 '11 at 18:23

I use

eth0 inet dhcp

I don't see the point of waiting when there is no link (the cable is missing) There is no way dhcp can get the address if there is no media. This is a bug

share|improve this answer
    
i use the same code, but i still have to wait for network configuration every time. –  Matthew Wilson Jan 7 '12 at 12:39

Seems like for me, the best solution for this problem was found at this linux site

Basically, still calling /etc/init/failsafe.conf , but commenting out the two sleep calls that caused the delay. I don't really see why they were added, since my network is configured fine without the need for a delay.

share|improve this answer

If you moved your OS from one machine to another it might be a good guess that udev created a configuration containing the mac address of your old network device which is different from the mac address of the network device from your new system.

Try removing the following file then reboot your system and see if this solves the problem:

/etc/udev/rules.d/70-persistent-net.rules
share|improve this answer
    
dachange thanks for getting me on the right track to solve a different issue ! i was getting a reset timeout on my wlan0 rlt8185 device when executing ip link set wlan0 up. Looked in the 70-persistent-net.rules file and commented out the line that added my wireless device, rebooted and now it's working! –  user71562 Jun 18 '12 at 19:56
    
This was also my problem. Thank you! –  Avio Jan 29 '13 at 9:32

I recently just had this same problem. I tried to go in and comment out the sleep time in /etc/init/failsafe.conf file and ended up with the system just continuously trying to boot. I fixed this error by booting into safe mode and droping into a root shell and doing the following so that I had rw privleges:

mount -o remount,rw / 

I then issued the following command which brought up the file so that I could edit it back to it's orginal state:

sudo nano /etc/init/failsafe.conf 

Save and exit, then reboot the system.

share|improve this answer
    
Can you, please, say what you edited in the file failsafe.conf. Did you comment out the sleep calls? I tried that some years ago unsuccessfully. –  Masi Jul 8 at 20:53
1  
Absolutely. After you are in the failsafe.conf txt, you just look for the sleep calls. I put mine back to 5, 40, and 59 respectively. I however was unable to succesfully comment out the sleep calls as it caused the system to go into continuous boot. –  clrn0979 Jul 19 at 7:35

protected by Oli Sep 4 '12 at 13:35

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.