Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I login to a unity session, the first time I press the Super key, the dash pops up but the keyboard focus does not go to it. I press the Super key a second time to dismiss the dash, and a third time to bring it back, and now it has the keyboard focus and I can type away happily. Every time after that the dash gets the keyboard focus as I expect it to. Anyone got any idea why? Or how to fix it?

I am using Natty/11.04 and I upgraded to Natty during the beta period which might have made the difference. (I am still using Natty) This behaviour has been the same since I upgraded and started using Unity.

Edit: As suggested by the first answer, I have now filed a bug about this.

share|improve this question

closed as off topic by Marco Ceppi Jan 25 '12 at 23:35

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Wait, are you using 11.04 or 11.10? Your question is somewhat fuzzy as to that point... :) –  jrg Sep 28 '11 at 19:34
    
@jrg - I have clarified the version - it is still 11.04 –  Hamish Downer Sep 28 '11 at 19:36
    
The linked bug has since been marked as a duplicate of this one: bugs.launchpad.net/unity/+bug/860805 Either way, bug reports are offtopic for Ask Ubuntu. Regardless, thanks for taking the time to report it! –  Christopher Kyle Horton Jan 24 '12 at 9:39
    
What to do with questions that describe known bugs? this has been reported on Launchpad and as such is now closed. –  Marco Ceppi Jan 25 '12 at 23:35

3 Answers 3

up vote 3 down vote accepted

Unless you think this is a configurable feature and wonder how to disable the bug, you should file bugs on Launchpad.net. This site is meant for questions and answers and your question is quite clearly more of a bug report than a question.

Since you're talking about keyboard focus, I guess maybe you're talking about the Dash and not the Launcher. The launcher is the strip of icons on the left side of your screen. The Dash is the one where you search for files, apps, music, etc. (In order to help you file a bug). Please provide as much details in the report as possible.

share|improve this answer

I also had this problem up until 2 or 3 days ago. It was solved by one of the latest updates that came with Ubuntu. It not only fixed this problem but also the other problem about right clicking an unity panel icon and not being able to select the context many the first time but only after doing it again. So both problems that do not get keyboard or mouse focus have been solved by the latest update.

Already checked in 2 laptops (Toshiba and HP) and on my Intel Desktop PC.

share|improve this answer

I've just done the latest updates in 11.10 and, as I type this, my launcher's focus is behind the Firefox window in which I am typing this. It's also behind Gimp and Thunderbird. It's useless to work like this, so I am forced to log out and log in after typing this.

share|improve this answer
    
You could just minimize your windows or use Ctrl+Alt+arrow key to switch to another workspace. The dash/launcher should still be perfectly accessible after all the windows have been (temporarily) cleared off the screen, no logout necessary. –  Christopher Kyle Horton Jan 26 '12 at 8:38
    
I "could" do that, yes, but that's not the point. The point is that it's not the intended behaviour and logging out and back in seems to be better in the long run (as opposed to minimising multiple times while hunting down the dash). –  Gonzoza Jan 26 '12 at 12:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.