Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Canon MP970 connected to a machine running Vista. I can address the printer in Ubuntu but selecting print does not produce a print.

Checking the print que shows my job as 'processing'. I´m thinking it may be a firewall or permissions issue but not sure what settings to look out for. My machine is running Ubuntu 11.04 64bit and the other with printer attached is Windows Vista 32bit with file and printer sharing turned on and Norton 360.

I´ve tried disabling the firewall with no effect.

While browsing other posts I saw one that made mention of using Samba to link Linux and Windows for file and printer sharing. Software Center shows a SMB/CIFS client installed but I´m not sure how to configure it. Tried another Samba client with a GUI but it didn´t seem to make a difference (it did find the printer share and list it in it´s GUI).

I opened a print window in the PDF Viewer which showed the printer status as unavailable.

I contacted Canon asking them directly if they have an alternate driver for the printer for Linux. They said no, and the age of the printer puts it out of support of that kind.

I found another printer that had a Linux driver for it (MP880) and attempted to install it to see what happened. The install failed (incorrect architecture). I believe it is due to the driver being 32bit and my OS being 64bit. I read a post about recompiling a 32bit driver into a 64bit one (however unstable) but I do not have that much experience to follow that path yet.

Seems that despite the amount of time we have had 64bit processors and 64bit OS´ there is a complete lack of support for 64bit functions. I fear the day we migrate to 128bit!

share|improve this question
    
just turn off the firewall in windows vista and try again . if it is working you can exclude the printer port in firewall and turn it on.. –  aneeshep Sep 29 '11 at 2:42

1 Answer 1

It is quite satisfying to be able to answer your own question sometimes.

Found a post of someone who figured out how to connect a printer wirelessly (http://ubuntuforums.org/showthread.php?t=1518425). Using their example as a guide.....

  • Downloaded the 32bit Linux driver for the MX860 and extracted it. (cnijfilter-mx860series-3.10-1-i386.deb)
  • Opened a terminal window and typed the following:
    • cd Desktop/cnijfilter-mx860series-3.10-1-i386-deb/packages
    • sudo dpkg -i --force-all *.deb
    • entered password
  • Opened printing manager
  • Deleted previous attempt at installing the printer
  • Clicked ADD and behold the printer showed up in the network list with the URI detais and all! (Canon-MP970-cnijnet:/00-00-85-E7-54-36)
  • Followed the prompts and test page printed OK!!!!!!

Hope this helps all who are using 64bit systems and are having trouble finding 64bit drivers.

share|improve this answer
    
So the solution is "use the manufacturer's proprietary 32-bit driver" :( Well, at least it works. :) –  Broam Oct 7 '11 at 15:05
    
Yes, but you need to force the install using the ¨sudo dpkg -i --force-all *.deb¨ command otherwise you get an incorrect architecture fault causing the install to halt. –  Andrew Oct 7 '11 at 15:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.