Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to install Mediawiki, which told me to update my libxml2 to at least version 2.7.3. So I've checked that and found /usr/lib/ to be installed. xml2-config --version also returns 2.7.6. But when reading the outputs of phpinfo(); it tells me the libXML Compiled Version is 2.6.32.

How can I tell PHP to use the correct libxml2, while avoiding recompiling anything by hand, as I like to use the Ubuntu package-upgrades in the future.

I'm currently running Ubuntu 10.04.3 (lucid) LTS and having installed the PHP5 and libapache-mod-php5 packages from the main sources (PHP 5.3.5-0.dotdeb.0).

share|improve this question
up vote 3 down vote accepted

PHP 5.3.5-0.dotdeb.0 indicates that the php packages that you have installed are from, rather than the main archive. These packages are not compiled for Ubuntu, but for Debian, and it's likely that these were built against an older version of libxml2.

You would be better off using the php5 packages from Ubuntu, or if a more recent version is needed, to use packages from a trusted PPA.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.