Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Ubuntu 10.04 Server as a file server. It is on the Windows Active Directory Domain (2008 SBS) and has been working well for several years (migrated to new hardware and upgraded from 8.04 a few months ago). Clients were originally all Windows XP, but now there's more Macs (12 Snow Leopard, 2 Lion) than Windows (1 XP, 1 Vista, 2 Seven), which are all still using Samba for sharing.

Today some users are having issues with various Adobe products on Snow Leopard (Flash CS5 and Photoshop at least) crashing or missing parts when opening files directly from the network, but they are fine when copying the file to the Desktop and opening from there. I have not had these issues personally.

What is the best method to determine what is going on?

share|improve this question

closed as too localized by qbi, Ringtail, Luis Alvarado, fossfreedom Apr 9 '12 at 20:28

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Do the logs in /var/log/samba say something unusual like tdb_lock failed on list? This seems to be a common problem hinting at some (lock) database corruption. – aquaherd Sep 28 '11 at 20:35
Hey @hood, to you still encounter problems with Samba? What have you tried in the mean time? – qbi Apr 7 '12 at 7:14
This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Thanks! – qbi Apr 8 '12 at 21:07
A Wireshark capture might shed some light on what is going on, but Apple breaks everything. Nobody in their right mind should be using Apple products in this kind of environment. – Ken Sharp Nov 27 '15 at 21:32