Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For installing mongodb i want to install these dependenciy so when i run this command

sudo apt-get install curl tcsh scons g++ xulrunner-1.9-dev libpcre++-dev libboost-dev libmozjs-dev

give me this result :

Building dependency tree
Reading state information... Done
Note, selecting 'libmozjs185-dev' instead of 'libmozjs-dev'
g++ is already the newest version.
g++ set to manually installed.
curl is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xulrunner-1.9-dev : Depends: xulrunner-1.9 (>= but it is not going to be installed
E: Broken packages

I tried setting source list and update and install but it is not happening ?

here is my source list .

deb natty main restricted universe
deb-src natty main restricted universe

deb natty-updates main restricted universe
deb-src natty-updates main restricted universe

deb natty-security main restricted universe
deb-src natty-security main restricted universe

deb sarge contrib
deb sarge contrib

deb hardy-security main

deb lucid-security main universe

deb lucid-updates main universe

deb natty main universe

please suggest what can be problem , how can i install it ?

share|improve this question
okay fine done by installing in sequece form this link… but want to know how it solved – Rahul Mehta Sep 28 '11 at 6:29

Don't install xulrunner-1.9-dev, it hasn't existed since Jaunty (9.04).

share|improve this answer
How to uninstall xulrunner-1.9-dev – S Gaber Jun 1 '14 at 5:14

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.