Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I once installed Opera by adding their repository to my sources.list:

deb http://deb.opera.com/opera/ stable non-free #Opera

Since then I get regular updates via the usual "apt-get update && apt-get upgrade", the last some weeks ago to Opera 11.51. Since then, Opera regularly (once every some days, sometimes more often) crashes (browser window disappears, and then the error reporting dialog comes up). (The same happens on OpenSUSE, where I had the upgrade last week, thus it is not Ubuntu-specific.)

This just occurred again (while I was typing an answer to a question on another Stack Exchange site) and I don't want to tolerate it any longer.

Is there an easy way to downgrade to an older version (like 11.50, which didn't had this problem), and still have the possibility to get the upgrade query when the next version comes out (which hopefully fixes this)?

share|improve this question
add comment

2 Answers

You can control which versions of packages are installed by creating version pins. You will need to add an entry to /etc/apt/preferences:

 Package: <package>
 Pin: <pin definition>
 Pin-Priority: <pin's priority>

By specifying Pin-Priority you can control if a package going to be replaced by a newer version when the latter comes out etc. A negative priority would prevent a package from being ever installed - I think that's what you could use in your case, if you want to skip a particular version:

 Package: opera
 Pin: 11.51
 Pin-Priority: -1

I didn't test it, but I think uninstalling opera, then creating a version pin and then installing it again would install an older version, and then upgrade it to a newer one when it's available.

You can read the documentation for more details. Typing man apt_preferences in terminal would also give you some info.

Of course, removing the PPA and managing versions manually is also an option, but where's fun in that? :)

share|improve this answer
    
Thanks, I'll try that. –  Paŭlo Ebermann Sep 28 '11 at 12:15
    
Okay, I tried this (with Pin: version 11.51). The effect is now that I can't install opera at all: E: Package 'opera' has no installation candidate. Looks like Opera's repository only provides Opera 11.51.1087, no older versions. –  Paŭlo Ebermann Sep 29 '11 at 11:29
add comment

Firstly Remove all programs which may be Opera related. Then go to Software Sources and disable the deb http://deb.opera.com/opera/ stable non-free #Opera repository, do a sudo apt-get update and then go to Opera's download site and download the version you want. You might want to check out Opera Next which is a beta version which has a version no of 12. This release might have solve your issue. Now a update can be done without disturbing the current version of Opera in your computer

share|improve this answer
    
Actually, I want to be able to auto-update my Opera version, not manually install an older version and stay there forever. –  Paŭlo Ebermann Jun 8 '12 at 19:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.