Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The mouse Logitech G300 is not working on Ubuntu (I'm using Ubuntu 11.04 x64). Left click is resulting in random click/movements and it's not an hardware issue, because it's working on windows. Maybe a driver issue? I noticed somebody is having the same problem: http://logs.ubuntu-eu.org/freenode5/2011/09/18/%23ubuntu-bugs.html

Any ideas?

share|improve this question

4 Answers 4

up vote 4 down vote accepted

There is a package in Software Center that may work for you - try lomoco

enter image description here

Further details on using this on the community wiki.

Start with lomoco -s to test compatibility.

share|improve this answer
    
Hello, thank you very much. When doing lomoco -s I have different lines, some saying it's not a Logitech mouse and one saying: Unsupported Logitech device: Unknown. I don't know if it's the mouse G300, or what. EDIT: probably it's not, because it says the same when the mouse is not plugged in... so this utility can't see the mouse? But the pointer is moving correctly and the scroll also is working correctly. Problems seems to be on mouse buttons. –  AnyWay Sep 27 '11 at 20:43
    
Ok, I've found which one is, it says: "Unsupported Logitech device: Unknown". –  AnyWay Sep 27 '11 at 21:14
    
ok - its worth posting a question on the developers mailing list - see the webpage and post the information they require: lomoco.org –  fossfreedom Sep 27 '11 at 22:48
    
Still not supported by lomoco (Jan '14) –  Chris H Jan 3 at 11:32

It's been reported on ubuntuforums in a thread linked to here that the logitech software doesn't work under virtualbox+WinXP. I got it to run, but only seemed to be able to configure 1 mode, and the mode switch button cycles the mode light off-off-red (the mode I configured last was red)

You'll want another mouse plugged in as well for this:

  • Set up a USB filter for the logitech mouse in virtualbox (you'll lose the mouse in your host OS when the VM is running)
  • Install the logitech software under XP
  • reboot the VM repeatedly until no more new hardware found
  • using the other mouse you plugged in earlier, run the logitech software and configure (bizarrely the G300 has an effect in the logitech software but doesn't move the pointer)
  • be sure that you are saving the config to the onboard memeory
  • close the VM to test (you can leave it paused)

Edit: Once the mouse has been configured under windows it will behave the same under ubuntu (or indeed if you take it to another machine).

This script from the linked ubuntuforums thread may help to set to mode on boot:

#!/bin/sh
G300_XINPUT_ID=$(xinput list | egrep --color=never "G300.*keyboard" | sed -r 's/.*id=([0-9]+).*/\1/')
xinput set-mode ${G300_XINPUT_ID} RELATIVE

Edit 2: If you use the VM for other things, you'll probably want to disable the filter after setting up the mouse, otherwise your mouse won't work with your VM running

share|improve this answer
    
@Alvar it helps users who are trying to use this particular piece of hardware under ubuntu - I'll clarify. –  Chris H Jan 3 at 11:29

I have found a more convenient workaround for the issue and maybe why it works fine on Fedora. I have just set the mode of the keyboard part of the mouse to relative. In my case:

xinput set-mode 12 RELATIVE

Where 12 is the ID of the G300 keyboard. Now that I have done that my mouse recognizes the keys the way I mapped them with the Logitech software under Windows.

Hope that helps you, guys get a better use of the mouse.

share|improve this answer

Okay, I digged some further into the issue. I already suspected the programmability of the G300 might have something to do with it. And when you enter

xinput list, it shows the G300 as both a mouse and a keyboard. In my case the G300 keyboard entry has id 12.

xinput list-props 12 gives all properties of the G300 keyboard. It includes this line:

Device Enabled (146): 1

which means that if we set the property with id 146 to a value of 0 for device id 12, the G300 keyboard is disabled.

Using

xinput set-prop 12 146 0

http://ubuntuforums.org/showthread.php?t=1849041&highlight=g300

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.