Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Unable to access NFS shares on Ubuntu from Windows 7. It just acts like the share can't be found on network. (NET HELP MSG 1222)

on client:

added NFS features  
tried "mount IP:/share z:" and the gui drive mapping  
tried with and without "AnonymousUid""AnonymousGid" DWORDs under HKLM\SOFTWARE\Microsoft\ClientForNFS\CurrentVersion\Default

on server:

exportfs lists the shares.
mount shows "nfsd on /proc/fs/nfsd type nfsd (rw)" (I think that's normal?!?)
have experimented with many options in:  
/etc/exports  
/etc/default/nfs-kernel-server  
/etc/default/nfs-common  
tried forcing no NFS v 4
after each change I'm restarting nfs service and re-exporting

I've been trying to figure this out forever. Any help would be much appreciated!

share|improve this question
    
do you have a linux user (on the server) with the same name as the windows user and access to the filesystem? –  sBlatt Sep 27 '11 at 21:18
    
Yes, I've also tried using other users from the client side as the client offers the ability to authenticate as somebody else. –  bumbling fool Sep 28 '11 at 22:45

1 Answer 1

up vote 2 down vote accepted

Finally, the issue was this default group policy needing to be disabled:
"Microsoft network client: Digitally sign communications (if server agrees)"
under gpedit.msc:
computer configuration>windows security>security settings>local policies>security options

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.