Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We use Ubuntu Server and in a days I have installed and configured Postfix+Dovecot+MySQL as it is explained here. From that tutorial I escaped creating certificates and antispam application. Right now it works good but when I try to send an email to GMail I am getting back my email with following content:

Reporting-MTA: dns; ns1
X-Postfix-Queue-ID: 19FDD1EA1826
X-Postfix-Sender: rfc822;
Arrival-Date: Tue, 27 Sep 2011 14:05:35 +0500 (TJT)

Final-Recipient: rfc822;
Original-Recipient: rfc822;
Action: failed
Status: 5.7.1
Remote-MTA: dns;
Diagnostic-Code: smtp; 550-5.7.1 [       1] Our system has
   detected an unusual rate of 550-5.7.1 unsolicited mail originating from
   your IP address. To protect our 550-5.7.1 users from spam, mail sent from
   your IP address has been blocked. 550-5.7.1 Please visit to review 550 5.7.1 our Bulk
   Email Senders Guidelines. w3si6844977eej.200

Our system has
   detected an unusual rate of 550-5.7.1 unsolicited mail originating from
   your IP address.

I tried to send to another outside domain and my email had been sent successfully. What can I do to resolve this problem?

share|improve this question

Sounds like your IP address was being used by a spammer before and Google blacklisted it, or that your system is sending email too quickly. I would follow the recommendations listed at as they mentioned.

share|improve this answer
up vote 0 down vote accepted

I have solved the problem adding postmaster email account to our domain. It was just one guess of my friend and I don't know why but it started to work normally.

share|improve this answer

Another problem might be that the client you are using is not setting the Message-ID header. To fix that with dovecot use:


Funny thing is, in my case it was the GMail mobile client for android which has this behaviour and failed to send mails to *

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.