Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When opening new windows in my Ubuntu 11.04 sometimes they are hidden behind the panel. I can grab them while pressing Alt+Button 1 but I would like to solve it so that they appear where they should.

The machine where this is happening is an upgraded one and I have seen in several new installations that this is not the expected behaviour.

You can see it in the following link:

Screenshot of the problem

share|improve this question
    
There's a similar bug in Oneiric, but couldn't find anything for Natty. Perhaps you should file a bug? –  WarriorIng64 Sep 28 '11 at 2:52

2 Answers 2

up vote 4 down vote accepted

I had this too on a machine that was all the way upgraded from Intrepid and the problem did not appear for a dummy new user I created for investigation purposes. This is how I solved it:

I logged out of unity, switched to a virtual terminal hitting AltF1, logged in as root, killed all remaining processes from my usual login with killall -u <login>, did a cd /home/<login> and a mv .gconf .gconf-old. When logging back in, the issue had disappeared with a lot of others for the price of losing some configurations which I considered a bargain.

After some diffing .gconf with .gconf-old with meld, I reached at the conclusion that some pre-natty compiz settings were the most probable cause, but your mileage may vary.

share|improve this answer

I had the same problem in Ubuntu 12.04 with GNOME. Indeed it could be fixed with compiz: enable "Place Windows" in Category/Windows Management.

share|improve this answer
    
sudo apt-get install compizconfig-settings-manager –  Antonios Feb 18 at 17:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.