Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got a problem with some of the texts not appearing in Ubuntu 11.04. I use the Spanish translation of Ubuntu and reinstalling the packages didn't solve the problem.

You will find some screenshots appended. In the first screenshot a "Label Empty" text can be seen where it should say "Log off" ("Cerrar sesión" in spanish).

Screenshot of the problem

The second one shows de Log off screen dialog, where te button is actually empty (says nothing) and there are some strange characters in the question dialog.

Screenshot of the problem

Does anybody know how to fix these?

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

Reinstalling the packages won't necessarily help because localization info was separated in Ubuntu. You may want to open Settings, Language support (icon with United Nations flag) and see if it prompts for localization not being completely installed.

The font issue is specially challenging because these Unicode symbols should be supported by default. If you type locale at a terminal, will the output look like LANG=es_ES.UTF-8 ? If it is, try selecting a different font like 'Ubuntu' or 'Sans' in the Appearance settings.

share|improve this answer
    
Strange things are happening :| gnome-language-selector wouldn't even start from the GUI. Launching it from the CLI says there's a segment violation, even when reinstalling it... will keep looking for a solution to that. On the other hand, the output of "locale" in the prompt says: LANG=es_ES@euro LANGUAGE=es_ES:es_ES@euro:en LC_CTYPE="es_ES" LC_NUMERIC="es_ES" LC_TIME="es_ES" LC_COLLATE="es_ES" LC_MONETARY="es_ES" LC_MESSAGES="es_ES" LC_PAPER="es_ES" LC_NAME="es_ES" LC_ADDRESS="es_ES" LC_TELEPHONE="es_ES" LC_MEASUREMENT="es_ES" LC_IDENTIFICATION="es_ES" LC_ALL=es_ES No UTF at all :(. Thanx –  tor Sep 27 '11 at 17:57
    
You might want to try sudo dpkg-reconfigure locales and I would sincerely recommend to switch to es_ES.UTF-8. –  aquaherd Sep 27 '11 at 18:17
    
After some investigation wondering how to set UTF-8 locales, the suggested solution deffinitely worked for me!! Thanx aquaherd :) –  tor Sep 28 '11 at 19:08
    
The solution is here. –  aquaherd Sep 28 '11 at 19:22
add comment

Changing the file /etc/enviroment this way could help:

LANGUAGE="es_ES:es:en_GB:en"
LANG="es_ES.UTF-8"

This page (spanish) describes how the locales work in Ubuntu, and lists the configuration files involved.

http://misdocumentos.net/wiki/linux/locales

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.