Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I read online (e.g. http://www.pinyinjoe.com/linux/ubuntu-910-openoffice-chinese-setup.htm) that ibus-chewing supports phonetic input of traditional characters using the pinyin system but I cannot get it to work under Ubuntu Oneiric. The problem boils down to being able to change the keyboard type which I cannot do using the interface provided. Any ideas?

share|improve this question

2 Answers 2

up vote 5 down vote accepted

I just managed to find a solution to my own question. I still haven't been able to get chewing to work the way I want, but here is a fix using the pinyin input method.

First of all, set "Show language panel" to always in the ibus preferences. At the moment, I cannot get the panel to integrate well with unity, so it does not seem to show unless forced to. Next, one of the buttons reads "traditional" and it toggles between simplified and traditional input. Voila!

One suggestion -- since the traditional characters tend to have more strokes, they can be tricky to read to an untrained eye (such as mine). For these purposes, increase the font size in the ibus preferences dialog (14+ looks best to me).

share|improve this answer
    
Very useful, also got it working with the pinyin input method, not the Chewing method, on Ubuntu 12.04. Thanks! –  Herman May 27 '12 at 19:53
    
Thank you! Extremely useful. One comment: it might be more useful to set the show language panel to 'when active' so the menu disappears when not using Chinese. –  geoffrey Mar 7 '13 at 6:27

Mine was a little different. I'm using Ubuntu 12.04.

I had to go "Keyboard Input Methods" and set "Show Language Panel" to "Always". After that, I went to any text box, pressed the Ctrl+Space trigger, then switched between Simplified and Traditional by pressing the "简" icon (changes to "繁").

share|improve this answer
    
excellent. Thanks for the tip, man, would have given up on this otherwise. –  e.m.fields Nov 25 '12 at 16:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.