Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I log into twice to a new instance of Ubuntu server built for Amazon EC2, both windows will be exactly the same. Anything I type in one is replicated in the other.

I never dealt with this when I built the image myself. Does anyone know about this? I normally like to have a few putty windows open logged into the terminal of my servers.

share|improve this question

3 Answers 3

up vote 2 down vote accepted

When you launch an instance in EC2 you have the option of supplying "user data" which is available to the instance at first boot (and later.) Ubuntu consumes the user data with a program called cloud-init, which is incredibly powerful.

You can disable byobu using the user-friendly cloud-config feature of cloud-init.

To disable byobu all you have to do is supply this two-line user data:

#cloud-config
byobu_by_default: disable

Full details about cloud-init here: https://help.ubuntu.com/community/CloudInit

Cloud-config syntax, including all the other amazing things you can do with it, here: http://bazaar.launchpad.net/~cloud-init-dev/cloud-init/trunk/view/head:/doc/examples/cloud-config.txt

share|improve this answer

Unfortunately, the pre-release Oneiric AMIs automatically run the screen command on ssh from a terminal which causes all of your ssh sessions to share a single screen. You can learn how to use screen to disassociate what your terminals see, or...

You can disable this on a given instance by typing the command:

byobu-disable

which will log you out. The next ssh will work fine.

Hopefully, Oneiric will not include this behavior when it is released, but we're getting awful close to that date.

Note: This post includes statements that express my personal opinions. Other people have different opinions.

share|improve this answer

As Eric said, you can disable byobu on the host with:

 $ byobu-disable

Once ssh'd in, you can disconnect from the current session but maintain a local shell with .

You can ssh in, and run bash instead of byobu:

 $ ssh -t <hostname> bash

And you can also make that permanent and affect all of your ssh sessions to Ubuntu/byobu hosts (where byobu > 4.0), by setting LC_BYOBU=0 in your local ~/.bashrc:

 $ echo "export LC_BYOBU=0" >> ~/.bashrc
 $ . ~/.bashrc
 $ ssh <hostname>
share|improve this answer
    
If you're using PuTTY, you can replicate the behavior of ssh -t <hostname> bash by setting the Remote command value to bash under 'Connection'->'SSH'. –  Kevin Pullin Jan 7 '12 at 21:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.