Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I am using Unity 3D, clicking on the systray doesn't work. For example, in the picture bellow:

unity systray

if I want to click on the Pidgin, Ubuntu One, Synapse,... icon, it doesn't work at all, meaning that nothing happens. I have to click on the Datetime indicator and after that go with the mouse on the left side until I reach to the desired application.

With Unity 2D this is not happening, everything is OK.

I have used this tutorial to enable the notification area:

share|improve this question

I also experienced this problem when I set the systray whitelist to 'all' (under desktop->unity->panel in dconf-editor). If you also set it try going back to selectively whitelisting all applications you would like to appear.

For me it solved the problem and I hope that it will for you too.

share|improve this answer

What have you done to your panel? One of the main goals of Unity, is to remove that horrible "systray" functionality from Windows 95.

You provide so very little information that it becomes difficult to help you and that seems to be a very customized ... something. If those are indicators, then you can try to restart them by pressing alt+f2 and typing killall unity-panel-service

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.