Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I disabled the checkbox "Save Session automatically" in Preferences => Session. Still all the programms start but I don't want them to.

Oh, strange thing: The Windowmanager does not start. I've got to log in at the console and enter DISPLAY=:0.0 xfwm4. It's somthing new, but I guess it has a common error source.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

What i tried is remove everything from ~/.cache/sessions

try:

rm -rf ~/.cache/sessions

share|improve this answer
    
also fixed the wm issue. –  Ludwig Sep 30 '11 at 10:08

Did you try saving a completely empty session? That is, you close everything you started, and then quit xfce while the checkbox is checked.

I wonder if it would solve your problem or it will refuse to overwrite the existing session if it would become empty.

edit:

Googling "xfce session file" yielded two promising results at the top.

  1. Xfce file locations describes the location of the files used by xfce, including the session.

  2. Xfce Wiki - faq describes your exact problem.

share|improve this answer
    
No, It's not always the same programm, it's exacly the same running when login off. Even the Windows-Manager, once run will be used in the next session. I'll try and make the session dirs read only. –  Ludwig Sep 26 '11 at 17:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.