Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 11.04 dual boot with xp. I have upgraded to natty from ubuntu 10.11 by using command do-release-upgrade some months ago.

The update manager asked for some updations included the package "linux-headers-2.6.38-11". I installed this package then.

I used command uname -r . It says current running version is 2.6.36.

By the command grub-install -v I had come to know that I'm using grub legacy only , not grub 2

Then I tried sudo update-grub and I verified that menu.lst file has an entry for for all kernels available in local disk. /boot/grub/menu.lst contains both kernels 2.6.36 & 2.6.38 and some other entries.The content of menu.lst is here

But on reboot the grub menu doesn't show the newer version of kernel. How to make kernel 2.6.38-11-generic as default kernel ?

  1. Even though grub 2 is default to natty, I hadn't. Why ?

  2. What are the things should I check before my future upgradation(to coming ubuntu 11.11) ?

  3. How to make a kernel (in this case 2.6.38-11-generic) as default kernel ?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

According to your menu.lst, Ubuntu 11.04, kernel 2.6.38-11-generic is the first and default option. Normally if you installed originally a release of Ubuntu prior to 9.10, it used grub legacy, and the upgrade process will leave that in place. I also notice that your menu.lst has an option to chain load grub2, so it looks like you somehow got both grub legacy and grub2 installed, which is not allowed. Did you manually install grub-legacy with a livecd?

At this point I would suggest trying to purge all traces of grub legacy and reinstall grub2:

sudo rm -fr /boot/grub
sudo apt-get install --reinstall grub-pc
sudo update-grub

During the reinstall step, you should be presented with a menu with a blue background asking you to check off which drives grub should be installed to. Make sure your boot drive is selected. If you don't get that screen, then you can force it by running sudo dpkg-reconfigure grub-pc.

share|improve this answer
    
I'm not sure about the installation of grub legacy. But there was a mess in booting process of my system. Anyway I'll try your suggestion. –  Sankaran Sep 26 '11 at 15:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.