Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For some strange reason (i.e. I don't have a tablet computer) Onboard, the on-screen keyboard, starts every time I log in. I've checked Startup Applications, but it's not listed there. What could be making it start like this, and how can I get it to stop?

share|improve this question
    
When you say that Onboard starts every time you log in, do you happen to mean it appears when you are unlocking the screen? (Because that's an issue I have encountered, but it might not be what you're having). –  Dylan McCall Jun 23 '12 at 1:05

5 Answers 5

up vote 4 down vote accepted

Looks like this bug is back in precise (tried using update manager, didn't work) This is the only solution I found:

Open a terminal window and type the following commands:

cd /etc/xdg/autostart
sudo rm onboard-autostart.desktop
share|improve this answer

It was a bug: launchpad

You can use Update Manager for fix

share|improve this answer

Let's try two things here. Open the Terminal application and type these commands:

gsettings set org.gnome.desktop.a11y.applications screen-keyboard-enabled false
gsettings set apps.onboard xembed-onboard false

The first command toggles whether the screen keyboard should be visible, just to make sure it is supposed to be turned off. That is the same as the option under System Settings / Universal Access.

The second command makes sure OnBoard does not show when you unlock the screen. This is the same as opening OnBoard Preferences and finding that checkbox. Sometimes that option gets enabled and it doesn't change back.

share|improve this answer

I opened onboard only one time, and ever since then it showed up when I was unlocking no matter what settings were set to.

I ended up uninstalling, I mean, I have never needed to, nor foresee a reason that I would ever need to use it.

So if you don't think you'll use it, I would recommend uninstalling. It's not really a fix, but you won't have to deal with it.

share|improve this answer
    
Kopkins, for that problem, see my answer. (It's an option in Onboard Settings that gets turned on unexpectedly). Uninstalling solves it too, of course :) –  Dylan McCall Jun 23 '12 at 1:58

On login page of ubuntu, click human icon on the top bar then uncheck onscreen keyboard.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.