Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On my Ubuntu UNR install, for some reason, I'm only able to switch the input language if I press Shift and then Alt. This is quite the opposite of what usually works -- on Windows and other Ubuntu/other Linux systems -- where I press Alt and then add Shift.

Anyone know why this is?

share|improve this question

closed as off-topic by Eric Carvalho, Anwar Shah, KasiyA, Charles Green, Volker Siegel Oct 29 at 14:06

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Anwar Shah, KasiyA, Charles Green, Volker Siegel
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Try more times for both next source and last source and press shift after 1 seconds that you pressed Alt key. it fixed my problem –  KasiyA Oct 28 at 11:54

5 Answers 5

up vote 1 down vote accepted

This is most likely a papercut.

see https://launchpad.net/hundredpapercuts

share|improve this answer
    
I'll just have to try and file it there. –  Jono Aug 15 '10 at 4:55

If it's only happening on your netbook, the issue is probably an incorrect keymap. Low-level tools for examining a keyboard include xkeycaps and showkey; this should at least tell you what keycodes are getting generated.

At a guess, you may the Alt key mapped as AltGr or a dead key; in that case the use of Shift first might be modifying it back to an Alt key. If that was the case however you would typically see this behaviour with only the left or right Alt (I've never seen a keymap with two AltGr keys).

share|improve this answer
    
It's weird, because it was a clean install of 9.10. –  Jono Aug 5 '10 at 6:56

Try this:

1. System
2. Preferences
3. Keyboard
4. Layouts (Tab)
5. Options...
6. Key(s) to change layout
7. Change to the key combo you want :D

I otherwise have no idea why it would be in a different order. I can only suggest swapping key combinations and then back to Alt+Shift.

share|improve this answer
    
Definitely tried that. And it only happens on my netbook, not on my other laptops. It's as if Shift+Alt is a different combination from Alt+Shift. Argh. –  Jono Aug 3 '10 at 11:30

Unfortunately, there are a number of long-standing bugs in handling switching between keyboard layout. I, for one, had problem with those in 9.10. For me they were fixed in 10.04. (FYI, this is the bug that bit me.) Perhaps and upgrade to 10.04, which is a stable one after all, might fix this. Alternatively you might use a different key - I use the menu key, which has no use whatever for me.

share|improve this answer

In my case it seems to be doing this whenever I set any Shift keys to toggle or cancel Caps Lock under the Miscellaneous compatibility options in the Keyboard Preferences (Keyboard Layout Options).

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.