Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Is there any way to install these packages via apt-get?

I found none of them with apt-cache search.

aRts        (for the arts plugin wrapper, and the artsd sink)
            http://www.arts-project.org
libdvdread  (for the dvdsrc)
            http://www.dtek.chalmers.se/groups/dvd/
            (optional: libcss for encrypted DVDs)
libdvdnav   (for the dvdnavsrc)
            http://dvd.sourceforge.net/
            (optional: libcss for encrypted DVDs)
        >= 0.1.9
libgsm      (for the gsm plugin)
            http://kbs.cs.tu-berlin.de/~jutta/toast.html
sdl     (for the sdl sink)
            http://www.libsdl.org
swfdec      (for the swfdec (flash) plugin)
            http://www.schleef.org/swfdec/
dtsdec      (for DTS audio decoding)
            http://www.videolan.org/libdca.html
divx        (for divx decoding)
            http://www.divx.com/divx/linux/
musepack    (for musepack audio codec/format)
            (http://www.musepack.net/)
nas     (for the NAS sound server sink)
            (http://radscan.com/nas.html)
libmms      (for MMS protocol support)
            (http://www.sf.net/projects/libmms)
libamrnb    (for AMR-NB support)
            (http://www.penguin.cz/~utx/amr)
libamrwb    (for AMR-WB support)
            (http://www.penguin.cz/~utx/amr)
libkate     (for Kate support)
            (http://libkate.googlecode.com/)
share|improve this question
1  
Why don't you tell us what you really want to do (ie. compile something but what)? Maybe there's an easier way to get you where you want. –  htorque Sep 24 '11 at 10:34
    
@htorque: I am installing this (cgit.freedesktop.org/gstreamer/gst-plugins-bad). And it has REQUIREMENTS file which requires those, but when i try apt-cache search thosename i get either huge list or non matched results. Which caused me 4 times of reinstalling 11.04 to 10.04. How can i exactly get those application using apt-cache search? –  YumYumYum Sep 24 '11 at 10:39
1  
Is there a special reason you want to compile it yourself? Have you tried installing the Ubuntu packages gstreamer0.10-plugins-bad or gstreamer0.10-plugins-bad-multiverse instead? –  htorque Sep 24 '11 at 10:47
    
@htorque: yes i did that from default package, but special reason is the default package has few elements missing does not shift, which i need to rebuild from source. –  YumYumYum Sep 24 '11 at 11:08
add comment

1 Answer

up vote 2 down vote accepted

Since you try to compile a package from source that's also in Ubuntu, you can try this:

sudo apt-get builddep gst-plugins-bad-multiverse0.10

However, this does not guarantee that you will get the right versions of the dependencies in older Ubuntu releases.

share|improve this answer
    
Genius. Thanks learned the trick :) –  YumYumYum Sep 24 '11 at 12:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.