Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Is there any way to install these packages via apt-get?

I found none of them with apt-cache search.

aRts        (for the arts plugin wrapper, and the artsd sink)
libdvdread  (for the dvdsrc)
            (optional: libcss for encrypted DVDs)
libdvdnav   (for the dvdnavsrc)
            (optional: libcss for encrypted DVDs)
        >= 0.1.9
libgsm      (for the gsm plugin)
sdl     (for the sdl sink)
swfdec      (for the swfdec (flash) plugin)
dtsdec      (for DTS audio decoding)
divx        (for divx decoding)
musepack    (for musepack audio codec/format)
nas     (for the NAS sound server sink)
libmms      (for MMS protocol support)
libamrnb    (for AMR-NB support)
libamrwb    (for AMR-WB support)
libkate     (for Kate support)
share|improve this question
Why don't you tell us what you really want to do (ie. compile something but what)? Maybe there's an easier way to get you where you want. – htorque Sep 24 '11 at 10:34
@htorque: I am installing this ( And it has REQUIREMENTS file which requires those, but when i try apt-cache search thosename i get either huge list or non matched results. Which caused me 4 times of reinstalling 11.04 to 10.04. How can i exactly get those application using apt-cache search? – YumYumYum Sep 24 '11 at 10:39
Is there a special reason you want to compile it yourself? Have you tried installing the Ubuntu packages gstreamer0.10-plugins-bad or gstreamer0.10-plugins-bad-multiverse instead? – htorque Sep 24 '11 at 10:47
@htorque: yes i did that from default package, but special reason is the default package has few elements missing does not shift, which i need to rebuild from source. – YumYumYum Sep 24 '11 at 11:08
up vote 2 down vote accepted

Since you try to compile a package from source that's also in Ubuntu, you can try this:

sudo apt-get builddep gst-plugins-bad-multiverse0.10

However, this does not guarantee that you will get the right versions of the dependencies in older Ubuntu releases.

share|improve this answer
Genius. Thanks learned the trick :) – YumYumYum Sep 24 '11 at 12:27

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.