Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I connect to the internet with a static IP. Connection is fine. After few successful connections to the DNS, the DNS becomes unreachable (PING still works using IP addresses). Restarting the ethernet connection solves the problem for few DNS queries before it stops again.

Does anybody have an idea what could be the problem? Many thanks in advance for your kind help!

Unsuccessful query:

dig google.com

; <<>> DiG 9.7.3 <<>> google.com
;; global options: +cmd
;; connection timed out; no servers could be reached

Information about my system:

Running Ubuntu 11.04 (with all updates).

$ uname -r
2.6.38-11-generic


$ i config (I replaced the ip addresses for this post)
eth0      Link encap:Ethernet  HWaddr e0:69:95:0e:99:22  
          inet addr:my.ip.address.here  Bcast:another.ip.address.here  Mask:255.255.0.0
          inet6 addr: one::more::ip::address Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:999950 errors:0 dropped:17458 overruns:0 frame:0
          TX packets:14668 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:204167642 (204.1 MB)  TX bytes:2175973 (2.1 MB)
          Interrupt:20 Memory:d1400000-d1420000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:192 errors:0 dropped:0 overruns:0 frame:0
          TX packets:192 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:14736 (14.7 KB)  TX bytes:14736 (14.7 KB)

$ head /proc/cpuinfo 
processor   : 0
vendor_id   : GenuineIntel
cpu family  : 6
model       : 26
model name  : Intel(R) Core(TM) i7 CPU         950  @ 3.07GHz
stepping    : 5
cpu MHz     : 2794.000
cache size  : 8192 KB
physical id : 0
siblings    : 8
share|improve this question
    
What nameservers (DNS servers) do you use? Have you tried using other ones? –  arrange Sep 23 '11 at 21:40
    
Please provide a copy of your /etc/resolv.conf file. –  Justin Andrusk Sep 23 '11 at 23:37
    
@arrange I am using my institutions dns server. Are there other ones that I can use / you would suggest. thanks for your help! –  user25517 Sep 24 '11 at 15:08
    
@Justin Thanks for your help. I will have access to the machine on Monday and post the information you requested. Thanks for your help! –  user25517 Sep 24 '11 at 15:08
    
@Justin# Generated by NetworkManager nameserver my.dns1.ip.here nameserver my.dns2.ip.here –  user25517 Sep 26 '11 at 15:20

1 Answer 1

Based on the data that has been provided if 'mydns1.ip.here' and my.dns2.ip.here' are the actual values then that's your problem. When you initially use DHCP it automatically populates the one it receives from your DHCP server. Since your are missing, I would recommend running:

sudo gedit /etc/resolv.conf

Replace the 'my.dns.*' values with the Public Google DNS addresses of 8.8.8.8 and 8.8.4.4.

Good luck.

share|improve this answer
    
Thanks for your help. I have tried that and it has not helped. I modified the printout for this forum to keep it as general as possible (there are the actual IP addresses in the file). I now see how this was misleading...Sorry for the confusion caused. –  user25517 Sep 27 '11 at 1:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.