Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My wireless works, but I have to right click the network manager applet and enable wireless on every boot which is annoying.

This is the output of rfkill normally:

x@Triela:~$ rfkill list
0: acer-wireless: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

When I rfkill block 0; rfkill block 1 this is what I get:

x@Triela:~$ rfkill list
0: acer-wireless: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes
2: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
When I rfkill unblock all, it clears all but the soft block on 0. My wireless is switched on/off by fn + f3. The indicator light for it is lit when connected, and blinks when there is activity, but it does not show me the on/off state.

I have tried everything I could find on the internet, but nothing has worked to unblock it or keep wireless enabled.

This is the output of my wifi card from lspci -v:

06:00.0 Network controller: Atheros Communications Inc. AR9287 Wireless Network Adapter (PCI-Express) (rev 01)
    Subsystem: Foxconn International, Inc. Device e034
    Flags: bus master, fast devsel, latency 0, IRQ 17
    Memory at d0200000 (64-bit, non-prefetchable) [size=64K]
    Capabilities: 
    Kernel driver in use: ath9k
    Kernel modules: ath9k

share|improve this question
add comment

2 Answers

up vote 7 down vote accepted
+50

You may be have a common issue with a clash between the acer-wmi kernel module and your Atheros driver.

Suggestion - copy and paste (line by line) the following into a terminal:

sudo modprobe -r acer-wmi
cd /etc/modprobe.d
sudo nano blacklist.conf

Then add blacklist acer-wmi as a new line at the end of the file.

Save (Ctrl+O) and reboot.

share|improve this answer
    
I think I've seen this fix somewhere else, but because the lack of instructions, I didn't try it. It works. Thanks! –  kevin Sep 23 '11 at 18:59
add comment

Run these commands in a terminal:

sudo rmmod -f ath5k
sudo rfkill unblock all
sudo modprobe ath5k
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.