Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The Update Manager is giving me a problem. Each time I hit the Check for updates button, I get the following error:

W:Failed to fetch http://ppa.launchpad.net/weather-indicator-team/pp/ubuntu/dists/natty/main/source/Sources  404  Not Found
W:Failed to fetch http://ppa.launchpad.net/weather-indicator-team/pp/ubuntu/dists/natty/main/binary-i386/Packages  404  Not Found
E:Some index files failed to download. They have been ignored, or old ones used instead.

I re-install the Update Manager and then it works properly, the same issue was with the Software Center I did the same and it worked. Any help?

share|improve this question
    
You have the option of getting an e-mail with answers to your questions once a day. You can scroll down to see this option. –  nitstorm Sep 23 '11 at 14:57
    
Welcome to Ask Ubuntu! It's never safe to publish your email address on an open web site. I've removed it from the post. If you're sure you want it to be publicly visible, you can undo this revision. –  htorque Sep 23 '11 at 15:19

1 Answer 1

up vote 1 down vote accepted

There is a typo in the PPA location ('pp' instead of 'ppa').

To fix this:

  • Press Alt + F2 and type gksu software-properties-gtk (press Enter)
  • After typing in your password, go to the Other Software tab and find the two entries that correspond to the error you posted.

    enter image description here

    [Just an example of how the GUI should look like, I don't have that PPA installed.]

  • Select each item, click on the Edit... button and fix the typo. The address should be

    http://ppa.launchpad.net/weather-indicator-team/ppa/ubuntu
    

    for both entries.

Close and try the Update Manager again.

share|improve this answer
    
got a window message saying---------Requires installation of untrusted packages The action would require the installation of packages from not authenticated sources.(weather indicator) –  sainath Sep 23 '11 at 16:28
    
Open a gnome-terminal and type the following: sudo apt-add-repository ppa:weather-indicator-team/ppa. This should take care of authenticating the PPA. –  htorque Sep 23 '11 at 16:35
    
after entering got this :--------Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp://keyserver.ubuntu.com:80/ --recv C1995DD92CCEB8E1865DBE2ADFB844B8BB91632D gpg: requesting key BB91632D from hkp server keyserver.ubuntu.com gpg: key BB91632D: public key "Launchpad PPA for Weather Indicator Team" imported gpg: Total number processed: 1 gpg: imported: 1 (RSA: 1) –  sainath Sep 24 '11 at 3:26
    
That sounds okay. Does the Update Manager now work? –  htorque Sep 24 '11 at 6:22
    
yes it is working :P –  sainath Sep 24 '11 at 17:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.