Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running 11.04. I want the system language to be in German. When I go to Language Support and Install/Remove Languages, I check the German box and Apply Changes.

However I'm told that the package is already installed and that there isn't any need for an installation. Expanding the Details shows:

Package [dbus.String(u'libreoffice-gnome')] is already installed

However, German doesn't appear in the Language for menus and windows list. How should I resolve this?

The problem is the same when I tried Esperanto and Afrikaans.

share|improve this question

3 Answers 3

I've just had the same problem.

While using Ubuntu 11.10 and trying to install French language, I got the error:

Package [dbus.String(u'thunderbird')] is already installed

As it would be too time consuming to uninstall, reinstall and reconfigure thunderbird (as adviced in some other answer), I looked around for a different fix.

What I found out was that I had some pending updates in the "Update Manager" utility.

All I had to do was to launch "Update Manager" and click on "Install Updates".

After that, it succeeded installing the French language pack.

So, my tip is: check for pending updates before trying to install a new language pack.

share|improve this answer
up vote 1 down vote accepted

Ok I resolved this. I'll answer the question just in case anyone else has a similar problem.

I went through and did sudo apt-get remove libreoffice-gnome. Upon which I tried again and got the same error except it was with libreoffice-draw, and then librdf0. After that it let me install German.

share|improve this answer

You need to log out and choose the language for your session. At the login prompt, select your user, then look at the bottom of the screen. You'll find a language selector there.

share|improve this answer
    
It only gives me the option of Chinese and about 5 or six variants of English. –  oadams Sep 23 '11 at 15:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.