Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I bought a Lenovo L520 with Intel HD 3000 Graphics. I installed Ubuntu 11.04 latest release. When i start up the laptop by default I get the start sound and then I see vertical colored lines flickering on the menubar and the mouse pointer which I can move. I fixed this problem already by editing the startup script in GRUB adding nomodeset. Now it starts up normally. But the problem is that the resolution is 1024*786 and this is also the highest resolution available. The display window says something like unknown, so I think that there are no correct driver installed. I also made a software update. What have I done wrong? 11.04 should have Intel HD 3000 support?

share|improve this question
    
try removing "nomodeset" but instead use "i915.semaphores=1" - does this work? –  fossfreedom Sep 23 '11 at 12:56
    
yes, perfect. thanks. –  Peter Sep 26 '11 at 14:29
    
excellent news - I've posted this as an answer. Please can you click the tick button to accept. –  fossfreedom Sep 26 '11 at 14:53
    
Hello, this appears to be this bug, which will be fixed in an upcoming release. –  Jacob Johan Edwards Feb 2 '12 at 22:38
add comment

closed as off topic by Marco Ceppi Feb 2 '12 at 23:55

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers

nomodeset turns off Kernel Modesetting (KMS) - this can (and does) impact the resolutions detected by the kernel.

My recommendation would be to look at using an alternative grub boot option such as i915.semaphores=1 - this enables kernel semaphores which can help with stability & graphical issues.

To make this change permanent on GRUB2 installations, change the following kernel command line entry in /etc/default/grub and re-running sudo update-grub to make that change permanent.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.semaphores=1"
share|improve this answer
add comment

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/777212?comments=all

Updating grub-gfxpayload-lists helped me on my Thinkpad L520.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.